Grids Issue

Hello all. I’m having an issue with Grids at the moment. I’ve searched here and at a few other places with no success, so my apologies in advance if this has been brought up before. When I turn on my modular, the Tap / Reset button on Grids is a solid light. I am unable to adjust any parameters, and no other lights blink at all. I do have +5V on my bus board, have tried different power connectors, and have tried different ports on the bus board. The red stripe is lined up properly on both the module and the board. Grids just doesn’t seem to respond to anything and that light stays lit. Any input would be a great help! Thanks in advance.

  • Has it worked before?
  • Is the pushbutton stuck?
  • Which power supply do you use?

Yes it has worked before. No, the pushbutton is not stuck. My case is an Enclave 12u with Make Noise powered bus boards. I’m not sure of the exact model of the power brick at the moment.

Where did you buy the module? You can contact the shop and ask for a replacement. They’ll ship me the module back and I’ll repair/refurbish it if possible.

I purchased it from Control. I will contact them. Thanks very much!