Frozen screen on smr4

hello all diyer !

i have a little problem ,after little short circuit on the main electricity line the screen of my shruti are frozen (grey square)

i can see nothing but the shruti work great ,i test with f1 a start for make a drone

i try to change the atmega with an other new i have from a 4pm kit ,and noting to say ,same result …

i have changed the screen with lot of difficulty and just the ambiant light are running ,some solder area is destroyed and i need to reconnect direct to the atmega
next step i try to change the trimer of contrast because he doesn’t run and if i make a short no difference

i’m little bit disapointed and i need your help

thank you really !

somes picture here :

http://www.flickr.com/photos/69546228@N05/sets/72157629975786620/

thank you pichenettes ,sorry for this misunderstanding

the number was not correct for the atmel

4th to 24 on atmel
6th to 25 …
11th to 26
12th to 27
13h to 28
14th to 29
15th to 68 ohm resistor (and after go to 30th pin on atmel)

the lcd was just controled by mcu ,ok ?
each pin of atmel control line vertical and horizontal sames as big screen of led :slight_smile:

what control the luminosity and contrast,this is only the trimer pot or other resitance around
i talk about the 68 ohm near the 15th pin she adjust the ambient light of screen or other function ?

do you think i can have a problem with the two resistance 2.2k near the trim pot ?

with checking i have found a problem

the signal doesn’t pass trough the 68 ohm

i try to change them

i have found

the trimer was out of order ,i have changed for à 10k and now the screen work fine

but i have a problem on the smr4 board ,the reso i really low and impossible to push up the filter for screaming …

i search from where is comming

1 and 5 are grounded ; 2 is connected to +5V ; 7 to 10 not used.

hello thank you

i have changed the lcd for a new ,and i have tested two lcd ,desolder the trim pot of contrast
not changed because i don’ have in more ,but i have lot of 10k /20k on other format

i go to check the schematics :

the 1st pin is ground ?

and the 2nd also or not used ?

3rd go to trimer

4th go to atmel 17

5th go to ground or not used ?

6th go to atmel 16

7to 10 ground or not used

11th go to atmel 15
12th go to atmel 14
13th go to atmel 13
14th go to atmel 12
15th go to atmel 11
16th go to ground

If the synth receives MIDI and plays note, but you see the grey squares it’s either that the controller in the LCD is damaged (very bad), or that there’s a broken trace or bad soldering point/connection between the MCU and the LCD module.

Use the schematics to find the connections between the LCD module and the MCU, and check that you get continuity between those.

It sounds like the LCD was destroyed somehow. Are you trying to replace it?