Frames - first keyframe doesn't go to zero

Has anyone had this issue with Frames?

I just bought a used Frames which seems to be in excellent conditions, from a respectable seller.
However, I’m having some trouble. If I had to sum it up, I would say: the first frame whose channels outputs are higher than zero randomly offsets the channels’ voltage of the frame before it

Example.
I’ll base the example on one channel, but the same happens on all four:

  • Add frame 1 at 7 o’clock (full CCW), with attenuator at 0. Add frame 2 at noon, with attenuator at Max (but any value other than 0 gives the same result really)
  • If I go back to frame 1, the output voltage should be 0V. Instead, it slightly fluctuates, randomly
  • If I add a frame between 1 and 2 (call it frame 1.5) and set its attenuator at 0, frame 1.5 now can’t steadily output 0V, whereas frame 1 now outputs 0V as it should have in the first place
  • All frames after frame 2 are ok, regardless of their output values

Hopefully this video clarifies things: IMG_8310.mov - VEED

Here I explain the video step by step in case it’s not clear:

Summary
  • Add frame 1, 2 and 3
  • Frame 1 and 3 channels are at 0, frame 2 channels are at Max
  • I scan from F2 to F3, no problem
  • Scanning from F2 to F1 reproduces the problem: the LEDs on F1 should be at 0, but are oscillating slightly away from that
  • Add F1.5, with all channels at 0
  • F1 channels now output 0V. The noisy output is now transferred on F1.5
  • Add F2.5 with all channels at 0. No problem, just like for F3
  • I now turn F2.5 channels to Max and F2 to 0. The problem is now transferred to F2, and F1 and F1.5 are fine.

It’s not just the LEDs: the outputs do put out voltage, and it’s not so subtle.

I’m running stock firmware 1.2, which I flashed again just to make sure.
None of the following things affect the result:

Summary
  • +10V OFFSET switch position
  • +5/+10V jumper on the board
  • placing F1 in a spot that isn’t full CCW
  • plugging a cable in any input or out
  • MODULATION knob position (unless I’m sending a negative offset into the FRAME input which “gets rid” of the problem but of course makes the module unusable)
  • the order in which I add/remove keyframes
  • the channel (it happens on all four)
  • the interpolation/response curve

The distance between F1 and F2 doesn’t seem to affect much the result, unless F2 is past 3 o’clock, in which case the issue is pretty much gone.

Am I messing something up myself?
If not, any idea what the issue could be and how to solve it?

Calibration: power the module on while holding the DEL button pressed, no input patched. Wait for 5s and release the button.

Thank you pichenettes.
I have already tried the calibration procedure, multiple times, but it didn’t help.
Since I couldn’t find any mention of it in the manual at some point I thought this was just for alternative firmwares, so I didn’t mention it in the post.

In this clip: with the Frame knob selecting frame 1, the knob lights show that it’s trying to interpolate between frame 1 (light blue) and frame 2 (purple).
Sorry for the crappy video, phone couldn’t show the effect better, but from 7 seconds on you can clearly see that the light is ebbing and flowing (it’s not a camera artifact, it was even clearer in person): IMG_8312.mov - VEED

Edit: I just realized that the noisy, Frame knob drifting thing happens on all frames except than the rightmost one.
I don’t know what to make of it.