Flickering Parameters, Not the Power Supply

Hi,

I finished building the Shruti1 but something is wrong with the display and stability of parameters. I’ve gone through all the troubleshooting points on the wiki and still, the same issue persists. I thought it might be the “invisible hand” problem mentioned in the build instructions, but the new power supply doesn’t solve the problem.

The Shruti1 makes sound and responds to MIDI, but the params are spinning in the sound output also. Here’s a video of the behavior: https://www.flickr.com/photos/wselman/15495135983/

Things I’ve done to troubleshoot:

  1. Power supply tested out fine with the meter while I was building the filter board.
  2. Buttons and LEDs worked passed the tests on the control board before I attached the LCD.
  3. I bought one of the recommended power supplies in the wiki, specifically, this one: https://www.sparkfun.com/products/298

Any suggestions?

Thanks in advance!

Bill

Have you enabled XT mode or programmer mode by mistake?

You hold down the encoder while switching on the synth to change modes.

Thank you! That did the trick! I’ll add this to the troubleshooting wiki.

Now that it works, I see the first pot is unresponsive. Time for more troubleshooting.

Ok, finally had some time to sort this out.

I have the four knob version, but I’m getting the flickering values if I load the Classic firmware. I only get non-flickering values with the XT Classic mode.

In the XT Classic mode, everything works except the first and fourth pots are unresponsive. Any suggestions?

You need to use the “classic” version.

Which power supply do you use?

Ok. Hmmm. I have flickering values in the classic version.

This is my power supply: https://www.sparkfun.com/products/298 I bought it specifically because it’s supposed to be a recommended one.

@wselman: Is there flickering when all of the pots are at either their minimum or maximum? Could you post pictures of your digital control board? Front and back please.

Yes, here are some more details when I boot into Classic 4 Knob mode:

The Mutable Instruments firmware info only flashes on the LCD for a split second.
The encoder is only partially responsive. It will show the different params (for example, cutoff, resonance, etc.) for a split second, but then immediately go back to the cutoff in filter mode.
First and fourth encoders are still not responsive.

The weird thing is that these problems don’t exist in the Classic XT mode.

This is only my second DIY project, so I’m wondering if I shorted something out or burned the board.

Pics:
https://dl.dropboxusercontent.com/u/1746796/P1010988.JPG
https://dl.dropboxusercontent.com/u/1746796/P1010990.JPG
https://dl.dropboxusercontent.com/u/1746796/P1010992.JPG

Thanks in advance for all your help. I’m super impressed with this community! :slight_smile:

Bill

The picture is a bit blurry, but it looks like you may have an accidental short between an unclipped LED leg and one of the switches. So sending some extra LED garbage may be the cause of this issue.

On the back picture the upper left solder pad on the fourth button from the left looks like it may be making a short. That would be the right LED for the envelope section touching the envelope selection button if viewed from the front. Can you see if there are any other potential shorts around the buttons or pots?

Thanks for taking a look, audiohoarder!

Apologies for the blurry photos. Here are clearer ones:
https://dl.dropboxusercontent.com/u/1746796/IMGP3439.jpg
https://dl.dropboxusercontent.com/u/1746796/IMGP3441.jpg

I’ll try cleaning that pad up. I think that may be more the angle from the original photo.

> The weird thing is that these problems don’t exist in the Classic XT mode.

It’s not weird at all. In the XT mode, the ADC scanning works very differently (all pots are connected to a multiplexer). You don’t have this multiplexer and all these pots, so in XT mode, nothing will change.

Things to check:

  • Bent MCU pins (37, 38, 39, 40).
  • Bad solder joints on those same MCU pins.
  • Soldering of the potentiometers pins.

If you have a scope, set all pots to their middle position and verify that the voltage on their middle pin does not wiggle.

I checked the MCU pins and solder joints at the far end of the MCU (away from the divot side). The pins aren’t bent. I resoldered one of the MCU joints, but the joints look fine now.

The pot pins solder joints look fine.

I don’t have a scope, but I did check the middle pin of the the pots with a voltmeter. The pins on the first and fourth pots are wiggling between 2.2 and 2.3 volts in the middle position (maybe this is the inaccuracy of the voltmeter?). The right pins on the pots are all at 4.9v.

> are wiggling between 2.2 and 2.3 volts

The multimeters have a low-pass filter, so if the signal is wiggling faster than a few Hz, it won’t be registered by the meter.

Ok, so, then we’re at still unknown. :slight_smile: Any suggestions or tests I can try with the multimeter?

I’ve been poking a little bit with the multimeter, testing various components. One thing I’ve noticed is that when I touch one of the leads on C7 on the control board with a multimeter, the param spinning freezes and the control board becomes unresponsive. This is without touching the com to ground or anything else.

Sound like it might be the issue?

No, this is normal, by doing so, you add your capacitance in parallel with C7, and thus prevents the quartz to oscillate.

Ok, any other suggestions or thoughts about what might be the issue? Apart from the flickering params, everything works as expected (MIDI in, sound out, etc.). Unfortunately, the flickering params make my shruti unusable.

Hard to tell if we can’t verify if the wobbling comes from the pots or the MCU.

Could you send me back the MCU?

Yes. I’ll ship the board. Let me know where to ship.

I think pichenettes meant just the ATMega chip, the 40 pin jobbie. Not the whole board.