Flashing DIY MicroGrids - Clock too slow?


#1

hi again. hoping that I’ve selected the right category now, here’s my question:

So I’ve built a microGrids. I’m using avrdude and usbasp.

I’ve tried the make -f bootstrap_all method first and didn’t succeed (I could write the firmware, but microgrids didn’t respond to clock input), also with bake. also with -B 4 or -B 10

then I tried this method:

  1. connect your usbasp or programmer and type: avrdude -V -p m328p -c usbasp -P usb -B 10 -e -u -U efuse:w:0x05:m -U hfuse:w:0xd8:m -U lfuse:w:0xff:m -U lock:w:0x2f:m -F to set the fuses correctly

(the -F parameter seems to be important, without that it was not working)

  1. type /usr/local/Cellar/avrdude/6.3/bin/avrdude -P usb -c usbasp -p ATmega328P -s -B 10 -U flash:w:/Users/your-mutable-folder/mutable-dev-environment/eurorack-mo dules/build/grids_bootloader/grids_bootloader.hex -F

(again, the -F parameter)

  1. type /usr/local/Cellar/avrdude/6.3/bin/avrdude -P usb -c usbasp -p ATmega328P -s -B 10 -U flash:w:/Users//your-mutable-folder/mutable-dev-environment/eurorack-m odules/build/grids/grids.hex

and microgrids started to respond to my clock input. however, too slow. the internal clock seems to be messed up a bit. it’s responding to my input, but too slowly.

I’ve also tried to set the fuses according to this tutorial: https://drive.google.com/file/d/1ij3SMkusbL2pcQ3qNHOqQblQwNoDTMC_/view . didn’t work so far.

any troubleshoot suggestions?

how can I properly reset everything on the atmega chip with avrdude? sorry. total noob here. I’ve flashed a couple of chips and that’s it.


#2

it’s not about the forum category.

you won’t get any help for DIY modules here. you should go to MW instead.


#3

oh, ok! sorry for that!


#4