First note sent to Shruthi doesn't sustain

First of all, there are some other topics that I believe describe the same problem, but no answer has been found yet.



I’m not sure what the rules are about reviving old threads vs starting new ones.
I’m gambling here and starting a new one :slight_smile:

The problem:
When I make a clip in Ableton Live containing for example four notes, the first note will just sound shortly, it doesn’t sustain.
It’s only when the song starts. If I start playing the clip when the song was already playing, the problem isn’t there.
I know it’s probably an issue with Live, not Shruthi, but has anyone been able to resolve it?

I’ve uploaded a video to demonstrate the issue:

Can you send a MIDI trace? MIDI monitor for example…

I’ve tried MIDI-OX. I can get it to display midi input values, but I’m lost how to monitor what Live is outputting.

Happens to me too. Can confirm.

Would it work if I connect my Midi out to a Midi in port, or does that damage my soundcard?

I think it should work fine. In the preferences of Ableton you can turn off the three types of incoming MIDI (Track, Sync and Remote) for the device you’re using, to be 100% sure.

On Mac in the Audio/Midi preferences of your computer you can create virtual MIDI connexions, there must be a way on PC as well… pretty handy to make MIDI connexions from an application to the other, or to a network.

Otherwise if you have Max for Live I think there are some patches for MIDI monitoring (although it would still be within Live).

No native Windows support apparently for virtual MIDI ports.

But I’ll try the physical MIDI loop tomorrow.

I’ve attached a txt file showing the MIDI output in both situations.

At first sight, it looks that the first note in the first situation doesn’t sustain because the Start message is given after the Note On.

Polite bump :slight_smile:

Have you configured the Shruthi to use external clock or internal clock?

External.

When the clock is set to external and the synth receives a “start” MIDI message, it cuts all sounds to reset everything that is tempo-synchronized (built-in sequencers, LFO).

I assume you want to lock modulations to the MIDI clock?

For now, a workaround would be to nudge the first note of your sequence a little bit after the beginning of the bar, so that the first note gets sent after the start message.

I see. Is that a feature or a bug?

Yeah the rate of lfo2 is synced with the bpm.

It’s by design. I don’t see why the sequencer would send the start message and clock after the first note rather than the other way round…