Firmare update fails to go through

So, I’ve tried updating from .98 to 1.01 and 1.02. Using the .syx file and the MIOS studio sysex tool. Tried multiple cables, several midi interfaces (iConnect audio 4+, a cheap just-the-cables-one, Faderfox UC4 MIDI through), many different send delays, from 250 to 2000.

This is what happens: The blinking starts as it should be, but at a random point between the 2nd and the 5th leds, the blinking resets to the first light again. Once the sending is done, the lights are off (I think), and rebooting it to synth mode does not work, all the leds switch on and nothing happens. I’ve gotten to the 5th led maybe once or twice out of tens of attempts. Should I try with another computer and yet another proper MIDI interface? (Running Ubuntu 16.04) Or is getting an AVR programmer my only possibility?

Thanks in advance for any ideas!

You can try using elektrons C6 tool. It has an option to insert small breaks/pauses between sysex packages. Maybe the MIOS tool is sending the stuff faster than the shruthi can handle.

If that doesn’t help, another problem might be the midi interface. Some don’t handle sysex mesages very well (especially when they exceed a certain length). But given that your results are inconsistent, it sounds more like atiming issue to me.

I used C6 with a variety of midi interfaces (MIDIbox Core with the “MIDI interface” demo firmware, Tascam US122L, Komplete Audio 6, some homebrew interfaces, etc.) to update my 5 Shruthis over the years. I never had problems after I configured C6 to insert small pauses in the transmission.

Cheers @TheSlowGrowth, I’ll try it. But I thought that the send delay function in MIOS Studio’s tool is just that – breaks between the sysex packets? I’ll try to borrow another proper MIDI interface from somewhere.

try c6 with the ‘delay’ set to 250ms.

For some reason I’ve always had to try multiple times to get Shruthi firmware updates through on my system (Windows 10, Audiophile 2496), even with C6 and proper delay settings

Updated my five (… no comment …) shruthis to 1.02 yesterday without any issues (using C6 on a Mac).

I did have to set the MIDI channel on the shruthis to 0 (worth a check on yours), and use a delay with C6.