DIY USB host - MIDI DIN converter - USBpal released


I used these for L1,L2,L3,L4:
Is that right? (I’m still waiting for a 12mhz crystal, but I’m looking at other solutions too to solve my problem)


These ferrite beads are pretty perfect!


so I installed the 12mhz crystal. I’m still having the same trouble as @sparky… Windows 7 64bit. tried vinprg and the IDE as well. no luck. all voltages check out, reflowed the vnc2 (not my first rodeo), no shorts or nothing. what else can I do? I usually don’t hit a wall like this, but I’m quite unfamiliar with the vnc2 environment and I can’t seem to find much discussion about similar problems out there… plz halp :slight_smile:


tried on a different computer, same result… really have no idea where to look. it’s the simplest project I’ve done in a while and I can’t make it work. very frustrating


Yeah, the VNC2 IDE is quite proprietary… I always recommend to get a working board from me :wink:

Seri, how far could you go? Did the IDE recognise the USB connected debug device which is plugged into the debug header of the MIDIpal board? Does it say “VNC2 32-pin package”?


it did not. the computer recognizes it, and I installed all the necessary drivers. Although when I hit refresh in the IDE, the debugger flashes once. But no, the IDE says disconnected, and VINPRG sais no debugger device, or something like that
Yeah I could get a working board from you, but then what’s the fun? :slight_smile: I’ve built tons of more complex projects before, all smd, so I’m in for the challenge:slight_smile:


This is how it should look like:


everything is the same for me, except it doesn’t show up in the IDE… :confused:


too bad. Can you provide a hi-res photo?


the header for the debugger is taken off, because i tried something. I checked all voltages and shorts, resistance.

I really hope you’ll see something i don’t :slight_smile:


SUCCESS!!! I don’t know what happened, but all of a sudden it worked :slight_smile: I tried it with a keyboard and it works, I couldn’t get it to work with my OP-1 tho… still trying


Your hardware job also looks pretty nice. Well done!
The OP-1 seems to have several USB functions that can be selected. Look for a USB MIDI class-compliant device mode…


doesn’t seem to work. I tried it with an ipad, which should be the same case, and it works well. but not with the USBpal. has anyone tried this before with the OP-1? could there be a fix in the code maybe?


USBpal generally connects to all USB MIDI class-compliant devices and transmits all messages.
I don’t have a OP-1 to check and I didn’t found the specs if it is class-compliant or not. But referring to the manual you should try this:

Did you?


yes, this was the first thing I tried, but no luck… do you have any other suggestion?


You could check the USB interface characteristics of the OP-1. For this you can use the little tool USBview when the OP-1 is plugged in the computer. On the left side click on the OP-1 and search on the right side for the Interface Descriptor.

Here I did it for a Korg NanoKey:

InterfaceClass must be 1 which means Audio and InterfaceSubClass must be 3 which is MIDI streaming.
For your convenience I attach (36.7 KB).