DIY USB host - MIDI DIN converter - USBpal released


#101

Thanks guys. I just read up a little, and I see now that 13Mhz won’t do it! Hopefully thats the issue. Now I’ll have to wait a few days as I appear to have everything but 12Mhz on hand!


#102

OK, 12Mhz crystal installed. Still no luck. In this picture, it is connected to the PC and the green LED is lit on the USBpal. On the PC there is still no device found in the IDE. I’m sure its not easy to see any component issues here, but I’m pretty OK with SMD having built a lot of oliviers modules on OSHPark pcbs
Anything look incorrect?


#103

Hmm, it’s not easy to see on the picture but maybe check the direction of D2? You should have 5V on that alternative power header if it’s OK. (It looks a bit like there is a line on D2 at the wrong end).
edit: Oops, I should have read that twice, if the green LED is lit, that’s not it…


#104

Could you check (with a sure hand) the voltages at the supply pins and the oscillation at the crystal?
Here is what it should show:


#105

All the voltages check out ok, the same as yours. I only have a little DSO138 1Mhz $15USD (!) scope, so I can’t check the clock. I did wonder about how the crystal was after replacing it, so I removed it and re-soldered it “on the top” of the board, so I could see that the top tracks were ok - and they were.
What’s next, the VNC2-32? I have a spare, and I can remove it ok if necessary.


#106

Hmm. Maybe. You are sure you did not mix up any capacitors? In particular C3 and C4 will break things if they are the wrong value (no clock).
Also, make sure you didn’t do what I did fifteen minutes ago, I inserted the USB cable into the debugger just far enough for the +5V to make contact, but not the data wires… I though for a minute I might have broken it somehow. Phew! :slight_smile:


#107

Good thought @larsen. I was pretty sure I was right. I replaced them to be sure. No change :frowning:


#108

Since all voltages are ok and the crystal and 18p load capacitors are double checked I tend to think the problem is more PC side. Do you use real windows or virtual? Do you use a hub? Maybe you could give some details about your PC system?


#109

@Picard. Its virtual (VMWare on a new iMac). No hub. Tried different USB mini cables - both of which were tested with other devices.
I tried this originally in a 32-bit Win 7 VM as well as a 64-bit Win8.1. I thought about the PC side first, since I heard about some issues getting the FTDI virtual serial drivers to replace the windows ones (which they appear to have done).
It appears the VNC2 debug module is just a USB-serial (which shows up in VMWare before I connect its USB port to windows).
When I click the refresh in the Debug portion in the IDE I see the red LED blink once on the VNC2 debug module, like it is polling the board, so I think the communication might be ok there.


#110

@sparky Do you have a chance to try it with a real Windows?


#111

I dusted off an old Windows 7 PC. I got exactly the same results as my 2 VM’s.


#112

Hi Picard
Could you tell me the make of the enclosure for the usb pal as I’d like to use one for a similar project.
Thanks


#113

@gabby I used this one of a German manufacturer.


#114

Thanks. Where did you buy it?


#115

Is this still available?


#116

Yes. I would be interested in one PCB!


#117

Yes. Status is ‘in production’.


#118

It is wonderful! I would like to buy this. Is that possible? I live in Russia.


#119

Also very interested in buying one. good luck with the production


#120

I actually prepare a new batch…
Please send a private message if interested.

@dim I never shipped to Russia before.
Is there any experience out there? I’m in Germany.