Disable osc keyboard tracking?

“The oscillators’ pitch always track the note played on the keyboard. However, this can be disabled by applying a negative modulation (amount: -63) from note pitch to oscillator pitch.”

I tried this and even -63 just seems to reduce the tracking rather than disable it. I wanted to try out a patch where one oscillator was just a drone and mess around with different mixer modes but I can’t disable the tracking as the manual describes.

Has anyone else had any success with this? I was expecting it to work a bit like negative note>cutoff modulation where the cutoff becomes completely static.

I think the issue is probably due to the fact that the filter cutoff range is 0 to 127 while the mod matrix range is 0 to 126. (63 * 2). I’m not sure how to get around this…

No, disabling filter key-tracking works great, it’s just disabling the oscillator key-tracking that doesn’t seem to work. I must be doing something wrong because the bit of the manual that I quoted is pretty clear that there is a way to do it.
I tried sending -63 from note to osc1 pitch, osc2 pitch and osc1+2 pitch to no avail (I also tried sending it to fine pitch but I wasn’t really expecting that to work).

Hmmm… Can you try using two entries from “not” to an oscillator, with an amount of -63, in the modulation matrix?

I will look at this later. This seems to be related to a pitch question that happened a while ago. Basically, someone wanted to know if they could pitch a waveform by more than one octave via the mod matrix. It wasn’t as easy as assigning the same modulation twice. There was a work around to get two octaves though.

Also, to turn off filter key tracking 100% you need to have a total modulation of -64. That means you can add up two note > cutoff at -32 modulation slots to turn off filter key tracking completely. Any more than -64 does invert the filter key tracking. Useful!

@pichenettes: If you do work on a “Shruthi 2”, can we get a mod matrix with values that range from -127 to 127? That would seem to fix issues like this, and save modulation slots. :slight_smile:

@pichenettes:

Hah, can’t believe I didn’t think of that! When it didn’t work as described in the manual I just assumed I was using the wrong mod destination. It didn’t occur to me to double up the modulation amount by using another slot. I’ll try that soon.

@audiohoarder:

Oh, I didn’t realise. -63 had the cutoff moving so little that I guess I didn’t notice!

@pichenettes:

Ok, I had a go at using multiple modulation slots and what I found is that each instance increases the octave by 1 semitone. So one instance of -63 = 13 tone equal temperament and so on.
**
EDIT: Wait no, it seems less linear than that (in a musical sense, which I know isn’t really linear). The size of the octave depends on where you are on the scale.
End edit.
**

I must be doing something completely wrong, can anyone point me in the right direction?

@pichenettes: Hmm… a third instance of note > osc1~ at -63 seems to start undoing what the other two did but two instances isn’t enough. What am I doing wrong?

I’ve had the same problems trying to disable keyboard tracking using the above method does not seem to work for me

@martindunne:
Thanks for trying. I’m beginning to wonder if the manual is wrong…? That would be a pity, because some droney patches where one oscillator is disconnected from the keyboard would be great and it opens up interesting possibilities for the sync and ring sounds.

The manual implies this should be possible and I really hope I’m just being stupid.

I have tried to disable the key tracking of osc2 with a few methods, but they all just stop working.
From the manual: osc2: Coarse oscillator 2 pitch, in a -16 / 16 semitones range…

So what this seems to imply is that there is a cap on the amount of modulation for the oscillators. I have tried several combinations, and they all about max out at 4 note to osc2 pitch at -63. I got the “best” results using two note to osc 2 pitch at -63 and then two op1 to osc 2 pitch at -63 where op1 = note + modwheel where the modwheel = 0. So in total 4 totally inverted note outputs did not turn off the key tracking.

When it comes to using the Shruthi as a drone box it is best to pick one midi note and stick with it. You can modulate the relative pitches of the oscillators with the internal modulations or external CCs that way. After all, how many drone boxes are there with chromatic pitch tracking?

One final suggestion, you can look at implementing a duo ring and duo sync mode in the oscillator operator settings. Probably a lot harder than it sound though. If this did work, you would just use oscillator one as your drone oscillator, and oscillator 2 as your chromatic oscillator.

EDIT: While I was at it, I decided to check if the maximum negative cutoff modulation via note was two -63 routings, and I am able to stack up to 4 and still get modulation.

Hmm, well I wasn’t thinking of straight drones but rather patches with a drone element (in the manner of bagpipes, hurdy-gurdies, appalachian dulcimers etc but obviously with the drone gated along with the melody. I’m a folky at heart). Duo mode does seem to be the only way to do straight melody+drone (but a bit of a pain to play) and adding duo-sync and duo-ring modes would I guess be one way of realising the sort of thing I’m trying to do.

Thanks for also trying to get it to work! I guess the manual is inaccurate? Maybe this used to work in an old version?

But if I was to accept that the pitch tracking can’t actually be turned off and start patching the firmware, I wonder if there would be an easier way of disabling the tracking than trying to extend duo mode with sync and ring modulation. Meh, I wouldn’t know where to start anyway. The extent of my ‘programming’ experience is messing around in Jesusonic in Reaper.

Could you point me to the part of the manual you are referring to? Or paste it here? I was able to figure out some interesting effects using the operators, but they definitely don’t sound natural. In fact using an xor on the note while using ring mod is very cool and almost sounds like 2 ring mods at the same time. There is also using note and prd to get some more chromatic dissonance with the operators.

If you are sequencing the Shruthi from a computer you should be able to send CCs for pitch easily. You will just have 2 octaves down or up from your base frequency.

It’s quoted at the top of the OP, that’s directly from the manual. :wink:

Ctrl-F a small part of that text on this page to find it in context:
http://mutable-instruments.net/shruthi1/manual

Thanks for the sequencer tip! Of course, if I set my drone at -24 then I’ve got a whole 4 octaves above it to play with.

> guess the manual is inaccurate? Maybe this used to work in an old version?

Probably. I’ll look into that.

I’ve removed the reference to disabling oscillator tracking in the manual. It worked in a very early version of the firmware in which the modulation matrix worked differently (but terribly inefficiently). A long time ago I did an optimization (computing it on 16-bit integers instead of 32-bit) which now prevents this to work.

I can’t think of any clean way of adding this feature in the UI. Everything in this synth is crowded. Time to say it goodbye and let it go?

As this is the first complaint about it in a long time, and since there’s no inter-osc FM, I’d say yes.

Yeah, this seems to basically be a pitch issue anyway. I’ve never though to disable an oscillator until now. I do understand that limiting the pitch modulation of an oscillator is important as pitching it too high or low at any given point will decrease the range a patch can be used in. Say a maximum pitch of C9 with a two octave pitch bend means that the patch will only work up to C7 properly. This is common on a lot of synthesizers.

If I had one last feature request to squeeze in the firmware it would be a super low BPM for the internal clock for synching LFOs. Like 10 BPM or even 1 BPM for really slow stuff. :slight_smile:

I’ve noticed that it’s not possible to do 1 octave pitch bends, which is kind of sad, but not something I can’t live with.

@Bjarne: In the manual, adjusting both oscillators pitch is limited to -4 semitones. The individual oscillators can be adjusted to-16. You can try bender to osc1 and osc2 pitch as two separate mod slots?