Didn't take me long to screw up the MIDIpal build

Are the components in the packages grouped according to the BOM? I think I may have mixed up the 100 resistors and the 100n capacitors. There are some components that do not have any markings on them, at least not that I have noticed.

Randy

The capacitors are white or yellow-ish and have no markings on them. You need to rely on the groupings (those that come by 2 are 22pF, those that come by 4 are 100nF). Or use a meter.

Resistors are black and have a white marking, if you have a loupe, you can read it. Those that come by 3 are the 100R, by 2 the 220R, and you can distinguish the 10k and 4.7k by looking at the marking.

See the pics

My MIDIpal looks great but I can’t get it to do anything so I have obviously screwed something up. All of the apps and parameters display fine but it doesn’t actually do anything. I’ve tried a few apps and there is no output. The LEDs do not light up and the Monitor app displays only a blank screen.

Any ideas on where I should start looking for problems?

Thanks.

if you suspect having swapped some components maybe compare your buiild with the pictures how the components in the different spots should look.

From your description it is clear that the MIDI in is not working (the monitor app does not work).

I am not sure if the MIDI out works. Can you try the sequencer or ear training game apps - they should generate messages on the MIDI out. Does the MIDI out LED blinks? Do you get messages?

The most likely cause of the MIDI in and out simultaneously not working is a short between the UART pins on the MCU (they are adjacent). These are pin 30 and 31.

The ear training game works, the out LED blinks. What colour is the out LED supposed to be? It ended up being red.

The LED colour isn’t important. But the standard is for the IN to be red and the OUT to be green. Is the IN really not working or is the LED simply not lighting up? it is possible the LED is the wrong way around.

If IN isn’t working then also check the diode is orientated correctly and the resistors are in the right place. An opto-isolator uses an LED internally to transmit to to a receiver. If you attenuate the signal going to the LED too much then it won’t light up enough.

Everything is oriented correctly and I re-flowed some of the solder joints just in case, still no MIDI in.

Randy

it’s look like my problem…
i have not tried something yet but i will post the result soon has i do something…
Nico.

Sure about the resistor value before the optoisolator? I put the wrong value in a MIDIBox project and the MIDI in didn’t work.

R3 should be a 220 ohm resistor.

Corrected: R3 not R2.

I’ll check that. I just measured resistance across the caps that I had de-soldered and then re-soldered into the correct places. I really don’t know much about this sort of thing but two of the caps give me .71 Kohms, and two are just an open circuit, no reading at all. Looks like I may have ruined C6 and C7.

All of the resistors around the optoisolator are fine.

I wonder if Olivier can mail another C6 and C7 over to Canada for me?

Randy

I think reading capacitors is different. On my meter it requires a different setting and I can’t use the probes. I bet your caps are OK.

  • You cannot read the value of a component while it is in circuit. A meter probes a component by sending current through it and measuring voltage (and vice-versa). When the part is in circuit, the current sent by the meter pours everywhere in the circuit, not just through the part under test.
  • Capacitance is expressed in farads, not ohms.
  • After a short time, a capacitor behaves like an open-circuit when subjected to a DC component.
  • To measure capacitance, you need a special bit of equipment (multimeters rarely do it).
  • If there’s something wrong with C6 and C7 the display, menus, etc. wouldn’t work.

If you have access to a scope, check pin 6 of the 6N138 - it should be at +3.3V at rest, with dips to 0 when there are 1s in the MIDI message. (you could also see that with some meters - +3.3V all the time, but short drops to lower values when some MIDI data is transiting).

I have only destroyed 2 parts over the past few years, and both were 6N138 - maybe the transistors in this chip are prone to electrostatic discharges? Could be worth replacing if nothing else works…

I really need to learn a bit more about this. I was fairly sure the meter readings for the caps were useless, thanks for confirming that. I added a bit more solder to the 6N138 pins and now I’m getting a MIDI stream passing through the MIDIpal! Not sure if it’s progress but certainly different.

Using the monitor app, the only thing that displays is a dot, one single dot, in the second from the left position, and the input and output LEDs are now flashing rapidly.

I really appreciate all of the help from everyone, thanks again!

Randy

Oh, I checked pin 6, using pin 5 for ground, and it is 3.3 at rest, moving briefly when a note is pressed.

I reset the box, and now the monitor works! The LEDs are still flashing constantly 'though.

Randy

I may attempt this build this afternoon. If not, tomorrow.

I keep forgetting to ask stuff, what is SW2 for?

Randy

I think I read that it’s a global reset? It’s in the manual.

So Randy, any words of wisdom for someone about to attempt this for the first time?

The dot and the constant flashing of the LEDs is probably because some device is sending clock or active sensing messages.

SW2 is a global reset.