Data led doesn't light up, no sound. [SOLVED]

Hi there, yesterday i have finished the ambika mobo and tonight my first smr4 voicecard, so i have no sound with this voicecard and the problem seems to be that there is no data exchange between the mobo and the voice card, neither the orange or green led are lighting up when connected or if i play some notes.

Thanx for your help.

  • Is the motherboard receiving MIDI?
  • Have you inserted the two A/B jumpers in the “A” position?

Yes the motherboard is receiving midi (notes & mod wheel), and the jumpers are in the “A” position.
Thx

before to get further into my investigations, i just want to know if it is possible that my problem is due to the IC3 chip (4050N hex buffer), because when i removed the chip from her protective support, i have broke up a pin, the last one on the left, i have resoldered the leg, everything seems allright but maybe… I have already ordered a replacement part.

The 4050 is used only for the SD card interface.

Is the voicecard +5V rail OK? Do you have a scope to monitor the signals sent by the motherboard to the voicecard?

For the voice card +5V rail i take the voltage measurement with the ground on MOBO port 7 and on the arduino header of the voice card connected on the JP1, so the voltage is +5V on the last pin of the connector.

Regarding the mobo voltage checking
The voltage are the same for the blue and red points (+8V, -8V) on the port JP1, JP3, JP5
but different for the port JP2, JP4, JP6, on red point voltage is +5V, and on the blue point it is +0,8V.

And no i don’t have a scope to monitor the signals.

thx

One thing you could try to do is launch the voicecard firmware upgrade procedure. Maybe the voicecard locked itself into firmware update mode due to too many failed power on/off cycles.

dumb question the film caps are not polarized? because i had a doubt during the built, and i followed what i have done on the shruthi.

i’ll try the firmware update procedure. thx

when holding S8 while powering up, i got the SD ERROR message

when i got in the about section i got the following:
ambika v0.1 / port 1 device ?

i will try to build another voice card and see if i got the same problem.

ok ok i guess i’m missing somewhere the ambika.bin and voice$.bin files

ok now i have put the bin files on the SDCARD, i have done the ambika upgrade, but i can’t do any upgrade procedure for the voicecard, only install is available, and it doesn’t work, so i suppose that my voicecard isn’t recognized at all by my ambika.

i have resoldered every contact on the voicecard, but it’s still the same, i don’t know what i have done wrong, my voicecard looks the same as nordlead’s one, seeing his picture.

Did you try putting the voicecard in an other slot? Maybe you have bad connection between the mobo and the voicecard on one of the slots.

yes i have already tried that on the two other slots, i will try to build a second voicecard, if it’s the same result, so the problem is definitively on the ambika mobo.

thx

because it’s hard to mount a second voicecard, with my eighteen month daughter who screams louder and louder “papa! papa! papa!” because she wants me to play with her, i have tried in the meantime to change all the chipsets from my first mounted voicecard, the result is the same…just in case…

Top Tip: go play with your daughter… Ambika will happily wait for you.

thanx for the tip fcd72 :wink:

my daughter (and my wife too) are sleeping now, so i have finished to build my second voicecard and… this one works perfectly, so i have to find what i did wrong on the first one and it’s not that easy to find…

PROBLEM SOLVED! thanx for all the support and your advices, while building my second voicecard i got a moment of doubt concerning the 20p and 220n ceramic caps, essentially because they were not the same as the ones provided with the kit. So i looked more closely to the photo posted by nordlead for his own voicecard, and everything became clear, i have inversed these two kind of ceramic caps on my first voicecard. So after several install/upgrade procedure (my first voicecard is capricious) everything is working like a charm (for now). One more voicecard to build… and i know that i want to buy the three other SMR4 voicecards ! it sounds so tasty!

Thank you all