:D arkanoid

as if it were my goal to do so i’ve once again managed to mod a control board so that it produces random symbols, if anything at all.
i’ve kept trying this and that, like swapping quartz & associates, even tearing off their pads & soldering them from the other side, resoldering all joints several times, testing the AVR in another device (works just fine), testing with different LCD (no change too), so i’ve reached the end of my ‘wisdom’

anamnesis:
sound works fine (ie filter control etc all work)
midi in works (out not tested)
leds not tested (not soldered yet)
buttons / pots / encoder+switch all work, ie i can switch in different menues and change parameters (also 2nd filter page etc), albeit not tested all menues due to being blind without display…
all synthesis parameters controllable via manuel’s editor, too.

i haven’t soldered the display yet, of course. so i have to take an awkward position to keep it connected, while trying to reproduce the behaviour.
very sorry for the crappy video quality, it keeps on refocusing all the time, as i’m apparently moving the display a little (and the camera’s shit)

1st either nothing appears, or a line of squares. then, on pressing a button sometimes a second line is added and if it likes to the squares change to random stuff. usually this content also changes with pot changes, but not this time (in the video). as you can see i triggered it this time with repeated clicking of the encoder’s switch.

weird? i did it again!

flickr video

any idea what it could be this time?

Is this another UFO coverage on that Video? :wink:

i already reported to ATIC

I get this kind of stuff all the time when testing a LCD module on a digital board without soldering it. The fact that you’re testing the LCD in an “awkward position” makes me believe it’s simply the same thing. It is either due to:

  • one of the data lines between the MCU and the LCD not having a good connection (so one of the transmitted bit is stuck at 0 or 1).
  • any connection being defective for the short time the MCU is powered on. At startup the MCU is sending a “switch to 4 bits parallel mode” to the LCD module. If the LCD module doesn’t catch it, it’ll expect to work using an 8-bits bus width and again, scrambled text. I often get this when doing the “testing the LCD without soldering it” trick - because my hand shakes a little when I am plugging the DC jack - so even if you hold the LCD firmly into place, you just need 1ms of shake during the power up sequence for the configuration sequence to be missed.

It’s a shame there isn’t a way to socket the LCD so you can easily try different ones without having to desolder.

a|x

oh that would mean i can just solder it? awesome!
i’ve attached the LCD even later, after power up. but strange that the last lcds worked just fine with that test, maybe i had it in a lucky position back then.
ok, i’ll report after soldering it!

you’re right Olivier, i just tried it with the lcd firmly connected and then powering up.
all fine yay!
thank you!