CvPal powered from a mac problem


#1

Hi!

I’m preparing a little set with a friend runing Ableton and my CvPal is behaving strange…

A usb sound card is pluged directly in is macbookpro and my CvPal is pluged in a powered usb hub along with other usb devices.

It works for 5 mins but then The CvPal disconnect from Ableton and also is sound card but my CvPal is still receiving power.

Is usb sound card is receiving power from an AC outlet not is lap top.

The CvPal works on my macbook pro at home on a powered hub with my sound card plugged in the thunderbolt.

Any suggestions for fixing this?

Thanx


#2

Faulty hub or cable?

Have you tried plugging the CVPal into different sockets on the hub, or using a different USB cable?


#3

It may be that the CVPal needs to be plugged in directly to the computer.

It lacks a dedicated USB controller chip, which it attempts to emulate using the tiny microcontroller IC, which also has to interpret incoming MIDI messages, drive the DAC etc.

The emulated USB controller uses a very slow communications protocol, which may not be handled correctly by the USB hub (it’s also problematic for some Windows machines, apparently).


#4

Thanx for your reply! I tried 2 different hubs and 3 different usb cables.

Weird thing is that when the CvPal is plugged directly into the laptop in one port and a powered sound card in a second port, the CvPal stops transmitting and the sound card and cvPal both disconnects from the laptop…

I’ll try pluging the sound card with an usb to thunderbolt adapter and the cvPal directly in the usb port…


#5

I had the exact problem with my CVPal - 2017 MacBook + Logic. Tried a few cables all had the same issue.


#6

Thunderbolt 3 hadn’t been invented when the CVPal was designed, so it’s quite possible that some vaguary of the way the Thunderbolt 3 > USB adapter works means the CVPal doesn’t play well with other devices when connected that way.


#7

Probably a timing issue. CVPal wouldn’t work too well with Windows due to polling being a bit too slow.