CVPal Flashing

#1

Hey Guys,

I am a programming rookie so bare with me, I have looked everywhere and tried everything. I have an Olimex AVR-ISP-MKII currently running the firmware for AVRDUDE. I’ve tried programming on Mac and windows, AVR Dude and Atmel Studio 7 and now i just installed the Dev Environment and STILL nothing is working for me.

Dev environment doesn’t recognize the code that i’m putting in from the build guide. AVR Dude says “USB receiving error” continuously. I’ve searched everywhere for instructions and have asked on every DIY group known to man.

Will someone please help me aka Walk me through the entire process of programming this thing? Everyone has said ‘compile’ this or something and i literally don’t know how to do these things.

Thank you for anyone gracious enough to help.

0 Likes

#2

Try a different USB cable. Many cables are power only, which won’t work.

0 Likes

#3

Hi Tim, I think it’s an avrdude v6.x problem with the avrispmkii. I had a similar error with v6.x (same error message), 5.x works perfectly. Trawling the avr forums it seems to be a common problem with this programmer and v6.x (even with correct firmware for avrdude on the programmer). Happy to be better informed though if I am wrong… :slight_smile:

0 Likes

#4

hey i’ve tried 3 different USB cables. Same result!

0 Likes

#5

Agreed, I’ve never worked with any of the *pals, but this sounds like the same thing I encountered flashing Edges. I resolved it with a note here (in the FAQ “I have performed a firmware switch. My drivers are properly installed. Still…”): https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/open-source-hardware

I ended up resolving the issue by compiling a patched avrdude, but it seems a 5.x version should work too.

0 Likes