Could a .WAV firmware update procedure work on Grids?

#1

I guess it could as I see “using namespace avr_audio_bootloader;” in the file bootloader.cc, but not sure how to do to make it work.

I tried without success:
I press the TAP button while I power on the module.
I have the .WAV going into CLOCK IN.
I play the .WAV.
Nothing happens.
No blinking, no upload.

In fact pressing TAP while powering on simply puts the module in option mode as usual.
Not in any mode ready to accept the firmware.

Of course I’m talking about a firmware which was tested and that I was able to flash via ISP without issue. I am interested in the .WAV procedure, as it’s easier to upload for the majority of users.

#2

The bootloader probably isn’t installed. There is a makefile command, iirc bootstrap_all that also flashes the bootloader. I guess you have only flashed the firmware without bootloader when your tried out my clock divider firmware.

1 Like
#3

EDIT: I WAS COMPLETELY WRONG; SEE BELOW.

I imagine that the inputs only accept DC, so that wouldn’t work for the audio update procedure. The clock in is just taking a pull-up to ground, so there is no adc there to read the audio.

#4

No, Grids accepts audio firmware updates.

If it doesn’t work on the OP’s module, it’s simply because the bootloader hasn’t been flashed.

1 Like
#5

Thank you very much for helping!
I previously flashed grids_bootloader.hex and after grids.hex, but today I’ll redo the all procedure and report back.

#6

Okay I did all again. Same result.
If I flash original Mutable firmware grids_bootloader.hex and after grids.hex and try to power on with TAP button pressed, I’m in option mode if I turn any pot other than clock pot.
And nothing happens when sending the .WAV file.

Can it be related to the cable I plug into the clock input or power on + TAP pressed is totally independent?

#7

What happens when you flash only grids_bootloader.hex and try to access the update procedure?

Also, have you correctly set the fuses?

#8

Fuses were set.
Anyway indeed once I now flashed only grids_bootloader.hex then the module enters in the update procedure mode. Cool. A big step forward.
Not far from the solution now.

Following now the update procedure, the LEDs are now flashing with success while the .WAV is playing, then stop when the WAV ends, like I think it should be in successful update procedure on other modules, but there’s actually nothing flashed, no matter which gear I use to send the .WAV to the module (computer, audio interface etc). The module simply remains in bootloader mode.

I’ll do again some tests with the Braids and the .WAV update for Braids to see if it works the way I do it and make sure I am not doing something wrong while sending the .WAV file itself to the Grids. I did this already with Braids a few months ago and it worked, but I’m going to do it again to be 100% sure before bothering with new questions.

#9

As a side note, I also had a weird appearance where the wav file finished (and blinky lights appeared as a confirmation) but the firmware wasn’t changed at all. Since then I only use my ISP programmer. But now that the bootloader isn’t working for you as well, I’m wondering if there is a bug somewhere. What compiler version are you using?

#10

I have installed:

  • avrdude version 6.3 (latest version)
  • vagrant Version 2.2.0 (latest would be 2.2.4)
  • Not sure how to find if needed avr-gcc installed version.
#11

Are we the only 2 who ever tried (without success)?