Clocked Grids loses its grooviness

I love creating beats with Grids when its being its own clock source. When I send it clock from ableton via a pittsburgh MIDI2 module, it seems to lose its grooviness, with most triggers going off at the same time or at equal divisions.

I’ve tried adjusting the clock resolution in the advanced settings but that only slightly helped (and i’m still not sure which setting is best).
I’m also not sure what type of midi track is best to send as clock source.

Any help appreciated :wink:

My feeling is that, rather than sending it clock, you’re sending it MIDI events that essentially retrig Grids… This would explain why the grooves are gone, as it would essentially cause Grids to mirror the events coming from the sequencer.

Edit: never mind - upon further thought this doesn’t make 100% sense

First thing: use 24ppqn.

Second thing: Grids’ shuffle/groove setting only applies to its internal clock. But this is not an issue since you can add shuffle on Ableton side to skew its clock.

Thanks guys. I’ll do some more experimenting.