Bricked voicecard [SOLVED]

I’m a moron.

I accidently named the Ambika controller firmware binary VOICE1.BIN and did (attempted) a firmware upgrade of a voice card via SD card. Now, this sound card seems to be bricked, i.e. it does not accept an install/upgrade of the correct voicecard firmware (via SD card) anymore.

Does anybody know if there’s some way around this, or is the only option disassembly, and flashing via ISP?

Thanks,
B

try this:

Press S7 while powering up Ambika to put the unit in MIDI firmware upgrade mode. In this mode, the unit is waiting for the firmware to be sent as SysEx blocks over MIDI. A .syx or .mid file with the latest data is available on the Mutable Instruments website. While receiving blocks of MIDI data, the unit displays the number of bytes loaded (the firmware takes up to 60kbytes):

Syx update…
4096
If you want to use a dedicated SysEx transfer tool, we recommend Elektron’s C6 tool available for both Windows and OS X, configured with a 250ms delay between blocks.

@altitude Thanks for the quick response, but I guess that’s for updating the controller right? I’ve got a fully working Ambika with only a single dead/unresponsive voice card. Cheers

Yes, you said “I accidently named the Ambika controller firmware binary VOICE1.BIN”, I dont know if there is a sysex upload equivalent for the voice cards… Seems odd that it would brick the card since the bootloader should be intact. Try flashing with progammer

@altitude Thanks. Yes, I wasn’t very clear. The mistake I made was upgrading a voice card (hence the name VOICE1.BIN) with the controller firmware. I guess I have do this the hard way with disassembly, purchasing a programmer, and get my hands dirty with ISP programming. I agree that it’s odd that the card doesn’t respond any more.

I sort of solved this by transplanting a programmed chip from a spare Ambika voice card I had lying around. My guess is that the reason re-loading the firmware via SD card does not work is because the bootloader was never installed in the first place. Maybe I’ll program the chip via ISP in the future. Thanks for the help.

Hi, my last upload my ambika got bricked. On boot, i will get “LCD just shows a row of blocks on the top row” and can’t update the firmware anymore. Can’t get it into emergency upload mode but sometimes it will boot but I don’t get the update option under preferences and weird characters. :frowning: