Branches, SQ-1, MS-20 Mini, Tides


Hi all,

Picked up my first modules, Branches and Tides, I seem to be having compatibility issue running SQ-1 into Branches and then triggering MS-20 Mini envelopes 1 and 2.

Output B from Branches appears to trigger Env 1 as expected but output A triggers both Env 1 & 2.

Is this due to S Trig and V Trig? I read somewhere that someone had similar issues with Grids.

Also, Tides output is normalled to +7v, I want to control the level with a +5v envelope from MS-20 Mini, however, the level doesn’t get back down to silence. Do I need to get something to scale or offset my envelope voltage up or down?

Thanks in advance for any advice



That’s weird because there’s no different in Branches’ output circuit for outputs A and B. Have you tried increasing the gate length on the SQ-1? That was the problem with Grids.

As for Tides’ level, it might be that the MS-20 mini envelope doesn’t exactly go back to 0.000V at rest (you can check that with a multimeter). Or that your Tides is not calibrated correctly (have you done anything related to calibration/alternative firmware with it?).


Hi Pichenettes,

Thanks for your reply. Tried increasing gate length / duty cycle on SQ-1, Branches still behaves oddly when probability set more to A. It’s like Env 1, triggered by output B doesn’t close, yet when I trigger the same Env from a gate source not connected to Branches (second gate on SQ-1), Env 1 closes as expected.

Haven’t changes anything on Tides. It might be a calibration issues as I’ve just tried controlling the level with two different LFO sources and the same thing happens. The level drops significantly but is still audible. Should I look at re-calibrating?




Does the same problem occur when you use the second channel of Branches?

Depends… Some LFOs and envelopes have badly designed output stages that do not exactly rest at 0. In such cases, you really need an offset to lower their rest level to 0V exactly. So I’d check first with a multimeter that the problem does not come from the LFO / envelope. If this is the case, the calibration procedure won’t solve anything.


Yes, same happens with second channel of Branches.

I’ve just tried using High Tide output of Tides to trigger Branches and I’m getting the same results.

Wondering if I’m doing something really daft. Currently have Branches Output A to MS-20 Trig In, Branches Output B MS-20 EG1 Trig In.

Branches seems to trigger EG’s when the LED’s go off.

Will investigate multimeter options, have tried LFO’s and Env’s from MS-20 mini and LFO from Moogerfooger MF-102.


Do you have any documentation/specifications explaining what kind of signals these inputs expect?

Does it appear to work when you swap what is connected to Branches’ outputs A and B?


Edit: Re-read post and my thought was already addressed.
Good luck!


Do you have any documentation/specifications explaining what kind of signals these inputs expect?

Only what I can see in the manual that they take trigger inputs, negative polarity which I believe is S-Trig on MS-20 Mini.

Does it appear to work when you swap what is connected to Branches’ outputs A and B?

If I swap the output around (Out A to EG1 and Out B to Trig In I get the similar results, EG 1 not behaving as expected, staying open too long. If I stop the sequence with EG1 open it won’t close at all. I have not experienced this when using SQ-1, only when using Branches.


Thanks Claude!


Ok, while it appears you folks are on top of this, if you are stuck and unsure what to try next, you COULD see if you can switch the gate polarity on the SQ-1 as a rule out exercise on the trig issue.

I don’t use my MS-20 Mini much these days, but I watch this topic with interest.


Thanks for the suggestion Claude, good to rule it out, just tried and had similar results, slightly different but I think that’s reflecting the different polarity.


Ok, borrowed another Branches from a friend, same things happen. Which is good as it seems that my Branches is fine.

Seems that the MS-20 Mini doesn’t like whatever happens to signals that go in to Branches.


Bummer! And mysterious and unresolved.


Yes, shame, but will find a use for Branches, I’m sure. The issue is less noticeable in toggle mode at higher tempo input, things behave much more as expected. Might try making some faster music.


Did you try to put some other module in between? For example if you have a spare sequencer with a trigger/gate out, you could trigger that with Branches and use the trigger out from the sequencer to trigger the MS-20. That could help in rule out some possible causes.


Hi Papernoise, thank you, great idea, will investigate. Bit short on modules at the moment, was wondering if routing through the ESP on MS-20 might help. I’ll try it out. Might be looking at getting Streams, should play quite nicely together I think :slight_smile: