Braids update - help please [solved]

i am trying to update my braids. which is the prototype with attenuator instead of attenuverter.
all i get is CRC ;(
i tried like 30 times with different output levels and got it to count to 001 (then strait to CRC) twice. most of the tiome, it goes from rdy strait to CRC
i tried with my phone, macbook and pc with m-audio delta soundcard.

other than the bootloader, the device seems bricked now. (dark screen when i boot without encoder held)

please help.

…unfortunately i do not own a jtag programmer yet.

Do you have a USB->serial dongle?

i have a usb-ftdi cable. does that help?

If it is 3.3V yes, it helps!

i am trying to find it right now…

i got it with my ansi midio kit from straytechnologies.com and never used it since i modded the mido thingy for midi input

Their FTDI cable seems to be 5V (at least the one they sell separately) so you might want to avoid that one…

you are right larsen thanks.
i can’t find it anyways right now.

any other idea? is there any way of doing it the audio way?
do i buy a 3.3v FTDI cable?

Something like this might help, but it is probably advisable to get a new cable instead, at least if it really is 5v… :confused:

Or a usb programmerThe cheap ones usually require some level of google fu to get working properly

what kind of programmer?
i got a AVR ISP Programmer, but thats a totally different interface, right?

Yes, the AVR ISP is a completely different thing…

I think getting a 3.3V FTDI cable is likely to be cheaper and easier to use than to buy a JTAG interface, but I’m not really sure of all the alternatives.

Any clone of this will do. Can program all my STM32F based modules (actually any STM32F that exposes UART1 RX/TX pins and a button).

thanks you guys.

just ordered this which is basically the same as the ftdi friend i guess.

allright. ftdi thingy in my hands :slight_smile:

i am trying to do the update with stm32loader.py
i already installed the serial library that was missing from my python.

does anybody have the braids 1.4 firmware as .bin. ???
in http://mutable-instruments.net/static/firmware/ there is only the .wav
…and olivier is probably still in lausanne

guess i have to go all the way and build the firmware myself.
(there are probably noob questions about the ARM EABI toolchain ahead)

.bin here

thanks.

i actualy managed to build the toolchain,edit the variable in the makefile and got to compile, but it threw some error and all i got in the build folder are a bunch of .d files.

i’ll use your file now. thanks a lot!

wait… anotherr question:

the pinout of my ftdi adapter (which matches the FTDI Friend) is:

DTR, RX, TX, VCC, CTS GND

while the pinout of braids (according to the silkscreen) is:

3.3v, TX, RX, X0, X1, GND

the fact that Ground and Vcc do not match make me think something is not right here.

… do i just make a little adapter? and if so: where do x0 and x1 go?

TX goes to RX ; RX goes to TX ; GND goes to GND.

X0 to X1 are not used for anything.

sorry to bother you with this so much, but i still can’t get it to work.

stm32loader.py throws an error:
"Can’t init. ensure that BOOT0 is enabled and reset device "
(as if there was nothing connected to the ftdi adapter)

could this be something specific to the fact that this is a braids prototype (like another version of the bootloader or something)?

i realize it is likely to me my fault though.
what could i be doing wrong ? or what could i educate myselkf about to get it right?