Blank shruthi screen and every other LED lit

I have had problems with the shruthi displaying lines on the screen and I replaced one of the smaller chips on PCB and the screen is now blank and every other LED is lit instead of every LED. Any suggestions on how I can get this working? re did any questionable solders and things like that so I’m not sure what could be next. I have been trying to fix this for about a year and i feel I am finally starting to see the light any help is GREATLY appreciated!

Looks like it boots in firmware update mode. Check the 595 and 165 (have you swapped them)? Also check the orientation of the resistor network.

I have the two chips in the correct places and replaced the one because I accdieently got two of the same. Fixing the placement of the chips is what got it past a worse issue and now I feel like I’ve found the problem…should I try to get new chips or is there a way to make it not boot in firmware mode? Thank you so much I feel im getting close All soldering is ok and I touched up anything that looked iffy

Sorry I don’t know the numbers for the chips right now, but the one on the top right of PCB is new and the one on the left is not

Check that:

  • You have not put the 595 in place of the 165 and reversely… I can’t tell from your picture.
  • The orientation of the resistor network.

I think that they are in the proper spots I will check again but referencing to the manual it looks the same…
What do you mean by orientation of network?
(Pardon my ignorance!)

Also, when I put the old chip back in (the far right one on top) the squiggly lines come back up which is the issue I was having before. And with this new one it looks like the photo above, is it possible that the chip to the left needs replaced?

Also, the grey and black box in the power supply the one near the edge of the board is getting a little hot, is that normal?

> What do you mean by orientation of network?

The resistor network RN1, is it soldered in the right direction?

> is getting a little hot, is that normal?

Yes.

Yes all the soldering is correct. The shruthi worked for about a year with no problems. I put in the bandpass mod and it worked great. I took it out and still worked. The next day is whenever I started to get the moving lines that I showed you the other day I believe.

When I take out the far left chip the last led stays lit and when they are both in the result is what happens in the picture…it’s been a year I’ve been trying to solve this issue and I feel like I’m getting close to solving it and it’s probably something silly.

Could it possibly be the atmega chip? Or is there a way where I could “reset” the shruthi?

Thanks SO MUCH for your responses!

> Could it possibly be the atmega chip?

Yes.

> Or is there a way where I could “reset” the shruthi?

No.

Ok, thank you pichenettes im going to try a new ATEMGA. Your the best!

Or is it ATMEL…again sorry for ignorance…do you know where I can purchase one? They need to be pre programmed yes?

ATMEL is the brand, ATMega is the family.

The chip is called ATMega644P.