Bad sound

Hi i just finished my Shruthi-1 whit SMR4 mkII filter. Had problems whit power: inverted regulators and wrong polarity on 220cap on + train. Thats solved. Now power flows great and controller works perfectly. The problem is there is no sound: Something comes out: sounds like a glitchy kick whit a white noise on the tail. The noise follows the envelope. I’m afraid I ruined one of the IC. I had the all mounted when I discovered the power problems. At first test all seemed to be ok. Now how can I discover where the problem is. how can I test the IC? Thanks, b.

Can you please a HighREs recording of the Sound - makes troubleshooting much more easy. Else its running around in the fog, blindfolded, in the dark.

And a photo of your board would help too!

here’s what you asked for.
https://dl.dropbox.com/u/831964/SH.zip
photo and sound
sound is preset n 1. playing C3 first note short second long Preamp gain is really high, in microphone range.

Have you tried tracing the audio signal through the signal processing chain?

What do you hear at each of these points?

Whit line preamp gain I hear oscillator on points 1 and 2 then on all the remaining points sound is dead.

Voltage at IC4 pin 7 when cutoff is at 0 and at 127?

pin 7 has 0.08 V at cutoff 0 and -0.02 (flickering 0.03) V at cutoff 127 measurements are made whit mutimeter DCV set at 20V.
they where taken whit out note played.
resonance was 0

Okay, we’re making some progress.

Now: remove IC6, and check the CURRENT flowing between pin 1 and pin 6 of the socket. At cutoff = 0 and cutoff = 127. The expected value is tiny so you can use the 20 or 200 mA caliber.

whit caliber of 200mA whit cutoff at 127 i have an oscillation between -0.08 and -0.03 whit cutoff at 0 oscillation between 0.01 and -0.04. My mulltimeter does not go below 200mA and is a 10 euro one. I have put the COM pole on pin 1 and V pole on pin 6.

Hmmm I don’t think these measurements can be trusted. The expect value is a few µA when cutoff is null to 1 mA when cutoff is set to the maximum value. I forgot to mention you have to remove IC8 to when making this measurement.

ok i remove IC 6 and IC 8. Now i mesure. My Multimeter whit out connections flickers from 0 to 0.01

You mean without the probes even touching the circuit?

OK now I got it. I was using the multimeter wrong (first time I mesure mA). did the measurements whit the right settings now at 20 mA and in both positions of cutoff I have a oscillation between 0 and 0.01. IC 6 and 8 are off the board.

Hmm, it’s hard to trust these measurements.

Assuming these measurements can be trusted, something is wrong:

  • Q2, Q3
  • 330k resistor
  • IC4 pins 8, 9, 10
  • C10

Assuming these measurements cannot be trusted and the expo converter works correctly indeed, the culprits could be:

  • IC6 and all resistors around it
  • IC7 pins 2, 3, 1
  • and C32

Check the soldering for all these parts!

And out of curiosity, your -5V rail is OK, right?

Yes - 5V is ok. But remember I had big troubles whit voltage before couse i inverted the 2 regulators (placing one instead of the other) and inverting polarity of C30. I had also inverted Q1 polarity. All of this as I was testing everything whit power and control board. Just after I discovered all this problems and solved them. Now V+ and V- are OK. Did you see (in pohoto) also that C4 and C8 are a little bit burned, while trying to extract Q1. Hope this last 2 are not a problem. Have no chance to test caps.

I will double check all soldering but did all the soldering whit magnifier and I’m not so bad doing them, a mess placing the parts but otherwise a good solderer.

OK I double checked all soldering points by you suggested with multimeter in diode mode (just to be sure). I found 1 point that did not have a good one: 330k resistor .
Now also this point is ok. and all the rest of the points you gave me to check are ok.
I also checked the 330K resistor and he does his job.
I checked values for all resistors around IC6 and it seems that 3 of the 10K resistors have different value: at 20k caliber I get a result of 5.29 (can it be that it’s a defective batch, or that they have been ruined by my voltage problems). I also checked all the rest of the 10K resistors and I get for some 5k values and for others 10K values. can it be?

So now I also checked all the other resistors and values are all ok. It seems only some of the 10k have 5k value.

The -5V rail is ok, checked again to be sure.
I redid the test on IC6 and the values are still 0 for 0 and 127 cutoff.

You cannot measure a resistor in circuit - it needs to be measured in isolation. Your 10k resistors are fine.

OK so if all resistors are OK, Where is the problem? Why the IC 6 test does not come positive?
Do I have to change all the IC? And what about the transistors?

C8 looks very overheated. can you post a picture of the solder side of the board? best is to upload it somewhere and link it here. just put exclamation marks around the url and it will show the pic.