Audio input problem, vca question [cem3379 filter board; solved]

i just tried to use my shruthi as a filter box for external audio signals, but i came across two problems:

  • the audio input doesn’t seem to work. it’s just dead. i opened the filter all the way, set both oscillators to “none”, and the sub-oscillator and noise to “0”, and when i hit a key, i hear nothing (except for the gentle click of the vca opening). i don’t have an input gain pot installed, and no, i did not forget to bridge those two solder points next to the audio input jack. what’s wrong here?

  • if the audio input did work: is there any way to permanently open up the vca without having to press a key? i thought maybe if i assign an offset to the vca with a value of “63” in the modulation matrix, that would open up the vca, but it doesn’t seem to work that way. so, how can it be achieved? i guess one way to do it would be the “test note” mode. but is there any way to permanently set the vca as always open for individual patches?

[edit: i use the cem3379 filter board and firmware version 0.91]

Your board is wrongly bridged. I have photoshopped your image to reflect how it should look.

Sorry for not being clear about this - it is routed differently from the SMR4 board.

There’s no way to keep the VCA open - the “test note” is the way to go. But really, I encourage you to try the various retriggering/re-envelopping effects you can get by triggering notes and envelopes on the audio input.

oh alright - that should be easy enough to fix. :slight_smile:

Aw hell… I haven’t tried my audio input yet, but if that picture shows how the input should be bridged, mine’s bridged wrongly as well. I copied the positions from the SMR-4 board without looking at how the pads are marked. I guess I’d better get that case disassembled, then. :frowning:

ok, fixed.

@ElectroDruid: i know it’s a bit of a nuisance having to unscrew it all, but it’s well worth it.

No joy for me :frowning:

I had some trouble removing the original bridge I’d put in between B10K and the middle pad, and ended up removing the top of the middle pad. My soldering skills aren’t the best on the planet, but they suffice - my desoldering skills are more of a problem. The pad on the underside of the board still looked fine so I made the new bridge between R1 and the middle pad and it all looks okay. But I’m still getting no audio through from my input source. I tried it with the “test note” (does that work on the Shruthi-1, by the way? I remember it didn’t on the Shruti-1) and also with input from a MIDI keyboard. I went through the same stuff as mic.w, oscillators set to None, no sub-oscillator, no noise, still nothing.

Is there anything else I can try, or do I need to open the case up again and start continuity testing? Where should I test? If the problem is with my new bridge, is there anything I can do to fix it, or will I have to live with an input-less Shruthi-1?

Yes, it works with the test note (and it worked on the Shruti too, I’m not sure what you’re referring too).

Do you have a scope? It would be very easy to find out with a scope where the signal flow is interrupted…

I don’t have a scope, unfortunately. How cheap can you go with scopes and still get something usable? I’m looking at the ARM DSO Nano but I haven’t used a scope before so I don’t know if that’s suitable.

My Shruti had a problem with the test note - I assumed it was the same for all Shrutis. Playing the test note didn’t seem to open the VCA, so the audio in didn’t work. It worked fine when notes were being triggered by MIDI input though.

Yes the DSO Nano or even the scope kit http://www.sparkfun.com/commerce/product_info.php?products_id=9484 are OK for that.

I haven’t yet got a scope (even with the cheap ones and the temptation of building the scope kit, money is tight for me at the moment) but I did do some continuity testing, and an attempt at a repair. To me, it seems that the overwhelming likelihood is that the problem is with the top pad that got removed when I removed the old bridge (the middle pad that’s supposed to connect to R1 but which I accidentally connected to B10K).

I don’t know exactly how the layers on a PCB work but I noticed there was a tiny bit of exposed circuit on the top of the board next to that pad, that I presume connects to C19. I tried flooding the area with solder to ensure there was a connection between my bridge and the bit of exposed circuit but it doesn’t seem to have helped.

So, what I’m thinking is that I could perhaps skip the broken pad entirely and run a wire from R1 to C19. Would that work? What sort of wire should I use? If I run it from R1, can I add the wire to the bottom of the board, or does it need to go onto the top? Also, my horribly messy first fix attempt runs across all 3 pads from the input - is there a potential problem with having the B10K pad connected to the middle pad and R1, or is that harmless?

Apologies for my admissions of my horrible hacks - although I’d like to think I’m pretty competent at soldering now, my knowledge of electrical engineering is still pretty shaky, and my techniques for unsoldering and fixing mistakes are even works.

Straight from the audio input “tip” metallic part to the first pin of the AC coupling capacitor

Cool… Does it matter whether I run the wire across the top of the PCB or across the bottom? It’s easier for me to do it underneath the board, since C19 is flush with the PCB so I’d have to unsolder it and move it to expose some of the pin, whereas just soldering it to the pad would be easier. Also, is there any type of wire that’s particularly recommended or should be avoided?

It’s ok above or below the board, but I didn’t have any picture of the bottom side of the board!

Has this been fixed on the v0.5 CEM3379 board?

The filter boards sold since 2011 have a little drawing showing how to correctly bridge the pads for the pots.