Anushri drums/ sequencer/ arp. Stopped working

Hi everyone! I have had my anushri for almost a couple months now all was well and we were meeting on a daily basis! Then, the arp. Knob
Did not respond. Although in counter clockwise position it will allow the synth to function. The start/ run button does start the drum or the synth.
Also, when in drum machine mode the the two lower rows of knobs make stepped oscillator tone. Anyways …i hope this is enough info to fix it.

Please post a recording of the “stepped oscillator tone”. No idea what you mean here.

What happens when you try to engage the arpeggiator? It doesn’t make any note at all, or you still get the notes you play on the keyboard?

Is the tempo correctly set (ie, not set on External clock mode)?

Ok… Got it! It must have been the clock settings because now it works. As for the stepped sound, only thing i can assume is that i had the hold function on accidently and was turn the pot fairly quick. Anyways i am probably at fault.haha Just super happy its working again!

Thank you .