Anushri Drums make a Blips when i move the density pots

Anushri Drums make a Blips when i move the density pot value from 0 to + and the same from + to 0 but all this happens only after the value 0 before the sound go out!

This happens to all density pot BD, SD, HH.


Listen the blips please!

Try replacing C2 on the main board. Try a firmware update (v0.92 here)

I wil try to make an update first because i dont have a capasitor to change the c2, thanks olivier!

i’ve make the update but i have the bigger problem at the close of density something like a buzz and the blip is only at the open of the density yet!
tomorrow i will change the capasitor if i find one!

i have replace the C2 with other capasitor and i take the same blips

any help PLEASE?


Did you manage to fix this issue ? Since I have the same symptoms:

When I turn sd,hd, hh density pots, there is a bliiip that cover all the other sounds :confused:

Any help will be appreciated

Hi dimduj
I have the same problem yet but now bigger than before because the noise from the drum is in the bass now. The vcf control has change and the fuzz is not so good “crispy”. I have change the LM13700N but nothing happens.
But i believe the noise source is from the vcf filter because is something like self oscillating.

I wanna ask you l : before the noise has you make a vcf calibration?

Στάλθηκε από το MI 3W μου χρησιμοποιώντας Tapatalk

Hi dimifrag,

Thanks for your fast answer… let me try to describe my issue :

When I switch on the anushri:
* Everything seems ok:
* no high-frequency noise. As far I don’t go to the drum section and touch one of the three density pot everything seems ok, I can play with the synth.
* I can hear the oscillator, fuzz is working, I can go to keyboard/drum mode and the led switch accordingly.

The noise issue only appeared when the anushri is in “run mode” after I modify the value of one of the three density pots.
* If i press ‘stop’ the noise perrsist somtehing like 10 sec and fade out.
* If i modify a density pot value again, the noise start again until I press stop and wait 10 secs.

As pichenettes suggested I upgrade to 0.92. ( I was on 0.91) and the behavior has changed a little bit:
* On 0.91 After changed density pot and heard noise, if i set all the density pots to 0% the noise stopped immediatly.
* On 0.92 After changed density pot and heard noise, if i set all the density pots to 0% the noise stopped after 10-30 sec.

I’ve listen on the “drum out” jack and the noise is on the “drum voice” + main out.

I have try with two different power supply (that work with an LXR and a p6) with no luck…

One thing that differs regarding the bill of material is the replacement of the styroflex capacitor C9 with a mica capacitor since mouser was out of stock (I choose this one:

I will try to post some pictures and sounds later :confused:

I haven’t made a vcf calibration for the moment… M build has just been finished yesterday …



@dimifrag I’ve finnaly solved the issue !

It was a defect atmega328p chip . I change it and burn the bootloader on a brand new 328p avr and now everything work as expected !

So you probably have a faulty 328p or a not properly burned firmware on your chip.

Hope it will help you to finalize your build, once it is done the anushri is simply amazing !



Hi @dimduj!
It’s amazing that you write…i will check it, first i’ll try to re-burn the firmware and if the problem exist i will change the atmega328p!
Can i fix this with this tools?
This AVR Microcontroller and this AVR Programmer from macosx ?


I’m also on macos.

I use a bus pirate for flashing AVR chips with avrdude :

Avrdude is installed from homebrew.



Hi @dimjud and thanks for your reply,
Now i have buy the sparkfun pocket avr programmer and i hope it work because is clone of the USBtiny from adafruit. I have download the CrossPack for AVR from, but how can i upload the bootloader and the firmware in the Atmega328p?
" I’m newbie in avr "

Στάλθηκε από το MI 3W μου χρησιμοποιώντας Tapatalk

Hi @dimduj
I have flash the bootloader in the new atmega328p and the 0.91 firmware working little bit better now.
But i listen the blip sound only if i run the anushri with the internal sequence for the first sound, if i play with the density pot of the snare first i listen the blip and then open the other instruments is seem ok. and in the analizer i saw noise in very low db and when stop the drums the noise stop after 5-10 minutes but i put a noise gate in the channel and is ok now)

Can i flash the firmware like the bootloader with avrdude?


with different command?

IIRC you only have to replace the bootloader .hex filename with the firmware.hex filename.

Hello @dimifrag ,

Sorry I was very busy and didn’t have the time to check the forum …

Strange that burning the firmware does’nt solve your issue…

Let me explain how I solved the same problem.

You dont have to compile source unless you modify the code…
The easiest way is to use homebrew to install avrdude.

Download the source code of the anushri from MI static public download section: here: and place it somwhere (in this example the path is /Users/Dimitri/Documents/anu_0.91.hex )

Next upload using avrdude.

I was using the buspirate so my command was (source:
sudo avrdude -B 1 -V -c buspirate -p m328p -P /dev/tty.usbserial-A7035URY -U flash:w:/Users/Dimitri/Documents/anu_0.91.hex

Assuming you use the usbtiny and windows (untested command)
sudo avrdude -B 1 -V -c usbtiny -p m328p -U flash:w:/Users/Dimitri/Documents/anu_0.91.hex

Some sources:

I cannot remember if I 've upload the bootloader :confused:

Let me know if you have made any progress