Anushri debug

Hello, while my wife jail me and the cats in my lab cause is cleaning home for christmas i’m debugging my anushri.
Ok…situation : midi sequencer connected and working (anushri led link up) but no synth section sound out from the main jack ---- i need a little help.
Supplies are tested and seems to be ok.
Sound path end in “Q” point (VCA input) , no sound out the lm13700 but chip are working cause i change it and more i hear fuzzed sound out on “P” point.
So i think there is a problem with Vca cv, in effects also vcf cv seem not working but is difficult to try definitively this.
If i check voltage in “C” point this is frozen at 0.8 V
Some suggestions , experiments to do , point to check?

Thanks and merry Diy Xmas for all ;o) ho ho ho ho

s. possible to reprogram atmega with arduino uno shield?

@iorobby
Nope, you will need some kind of AVR Programmer. Its not an Arduino inside the Shruthi albeit its an ATmega chip. Don’t get this confused, not all Cars that run with a 4 Stroke Petrol Engine are an Alfa Romeo…

are you suspecting the Atmega to be the problem?

thanks , yess …i would to try to reprogram the atmega brain , i suspect the problem is here.
This could solve definetively the problem before to start a massive (and very boring) debug.
I have a avr isp programmer (www.betemcu.cn) but i never try to use it and …yes…i dont know how to do :o( …i’m an analog man, i’m starting to undestand a little how to
cook something with arduino but avr is completely outerspaced for me.
Someone could tell me in very poor and simple robot-like language a procedure for to reprogram the atmega

The problem is most likely not the ATmega - in all cases i had (and boy i had a lot of troubleshooting) it was never a malfunctioning CPU. The ATmega is either dead or working correctly, there is no wear or half programmed/functioning to CPUs.

Check your soldering for continuity on the lm13700… Especially the ground points

Things that could cause the voltage at point C to have a wrong value:

  • Short between adjacent DAC pins
  • Short on the network connected to point “C” (something wrong near R43 - maybe a short between R43 and R44?)
  • It might also be bad soldering on the GATE jack causing the envelope to retrigger randomly (and rapidly)
  • In last resort, swap the two DAC chips in case one of them is damaged.

The probability that a damaged ATMega328p will work normally except for the section of code refreshing the VCA is ridiculously small.

thank you for the info,so i assume that atmega work correcly cause for example drum section seem to sound ok ,however all cv’s are frozen ,now i’m checking all components with the bom then i’ll try a general welds check and re-heat
are noticed some problems with dac’s mcp4822 and other chips and components in digital session?

…between a shrimp sauce , and other various fish cooking for the xmas dinner i substituted all digital chips excluding the two 4051 (no spare! :o()
Now cv seem to work but still no sound in jacks…this make me crazy…welds seem all ok ,apparently no shorts, i reheat all bad look connection…arghh!

ok ok solved! i’ve changed also the 2 x 4051 ( picked in my shruti programmer box) i’ve changed again the tl072 that drive the vca ota and my anushri sing like a bird
I think the 2 dac and some other digital chips (boh…i think the 74595 and 74165 ) was fried…very strange cause i’m always very heedful with psu.
Thank you to all who help me and save me from an avr reprogram bad trip!
Merry Xmas to all! Ho Ho ho ;o)

Have an exiting new synth DIY year!

great! now get yourself an ambika :smiley:

one ambika kit is already waiting for my welder on the table near me, will be my new year 1st project!