Another silly Elements firmware upgrade problem

Hi all,

I’m looking for tips to successfully update my Elements to firmware v1.1, or to get it back to functional after failing the upgrade. I’ll list what I’ve already tried below.

My setup is
Windows PC → USB into Scarlett 2i2 (2nd gen) → analog from the Scarlett into Mackie 402 VLZ3 mixer, then into Elements → analog into Elements left (burgundy) Ext In
Nothing else is plugged into the Elements nor the mixer
I have all sound turned down on the PC except my audio player (have tried with OcenAudio and VLC)

Some variations of the above:

  • A Mackie 802VLZ4 mixer instead of the 402
  • Direct from the Focusrite into the Elements (but I can never get the Resonator LED to light in this case, so I think gain is too low–that’s why I added the mixer)
  • Mono cables to the left inputs and outputs of the mixer, and also dual 1/4" mono to stereo 3.5mm; same with the audio interface
  • Applying gain at the mixer in different sections (channel vs. master out)
  • Running through a Tip Top Forbidden Planet as another gain stage (LP mode with cutoff frequency at max, and HP mode with cutoff at min–I’m suspicious of this in every case, but thought it might be a way to get to Eurorack levels without a true input module)
  • Mono 1/4" to 3.5mm cables from the left and right outputs of the audio interface into the middle (precision adder) section of a Links, Links output to Elements left Ext In; same with mixer left and right outputs

I’m playing the elements_1.1.wav file downloaded directly from Mutable Instruments’ site. I notice that it is a 48 kHz file, and I’ve verified that my audio interface is also clocking at that rate per its driver.

After starting the Elements in firmware upgrade mode (Blow at 12 o’clock, holding down Play button while applying power), I hit play on the file. I can get the Play LED to flash rapidly (with occasional pauses that I presume are either in the file or are something being written to flash), Exciter LED to light up bright, and the Resonator LED to light up dimly, with appropriate adjustment of volume knobs on the mixer, interface, and Elements (Blow). If I’m using the mixer, its VU meter is showing max green (no yellow or red to indicate oversaturation or clipping).

The file usually gets to about 5:26 or so and then suddenly the Exciter and Resonator LEDs both start blinking, and the Play LED goes solid. At this point, I can either hit Play to get back to Firmware Update Mode or re-power on. If I re-power without holding Play, the LEDs on the Elements all just blink a few times and then it goes dark.

If I hit the Play button, then either the blue (Exciter) or the purple (Resonator) light will be lit solidly. I’m wondering if there’s any meaning to which it is? I have been assuming blue (left) means gain too low and purple (right) means gain too high, but I get the failure in a variety of gain settings, and with one or the other LED lit afterwards, so maybe it’s just arbitrary based on when I hit Play after they were both flashing.

Sometimes if I just hit play again immediately after pressing Play, with no adjustment to gain anywhere in the system, the Exciter and Resonator lights both start flashing immediately.

At this point, I can’t think of much else to try. Any suggestions or tips are welcome! Thanks in advance for your time.

Just for the record: The incredible rhyme animal @pichenettes worked with me on this today. A side comment of hers–gain shouldn’t be a problem, and a lot of people even do the update from their phone–led me to try exactly that when I got off work. Mono patch cable from my phone straight into the Elements. 6 minutes later, I was as happy as the proverbial. So here’s just one more person grateful for BOTH a working module AND amazing warmth and support from MI.

If I were smart, I would have turned on airplane mode before I started to reduce the chance of alerts, but it worked out for me THIS TIME.

2 Likes