Another shruti at large

First, the detailed assembly pictures, and instructions where a huge help. This is my first attempt at building a kit like this. And those instructions are great.

Ok so my little creature is almost alive. I finished soldering the components today. Got a power supply (7.5v DC 300mA) and turn it on. The good news…it turned on. Also the lcd display shows values, it receives midi, and it is generating sound, The problems that I need to troubleshoot: The control board and the main board are not friendly with each other; navigation buttons are not changing the pages (the display reads “filter”). The knobs don’t seem to be doing anything either. That’s one, two; the bottom line of the display is flickering a bunch of parameters really fast, the top line does not change. I’ll have a multimeter probably by Thursday. Is there anything to check or do without that tool? Oh and I did not install the LEDs, but I could if that is causing any of this.

I would say definitely check that your ribbon cable is properly soldered and that the colors on one board coincide with the other. In other words, make sure that the GND cable (black, on mine; it might be different for you) is attached to the GND pin on the other board and the DATA cable (brown) is attached to the GND pin on the other board, etc., etc.

If that’s alright, check your solder work on the ICs and pots on the control board.

Make sure you’ve got the IC’s on the control board in the proper orientation.

also: does the flickering go away if you unplug the control board?

It really looks like a bad connection between the two boards - the main board doesn’t receive anything on the digital input (no button presses are detected), and the analog path for the pots readings seems to be floating, so it gets random noise and all the parameters randomly float.

Do the LEDs display correctly, or do you get a random pattern every time the unit is powered? That would be another symptom pointing to a problem with the communication between the two boards.

Can u make a photo of ur two boards? I think that’s the better way for helping you.

Ok the control board and the main board are friends. It was a couple solder points that where not soldered properly. All the knobs work and I can navigate all the pages with the buttons. I’ve been checking the different wave forms, the envelopes, I have not messed with the sequencer yet.

Now to something scary. The filter is not working and the output volume is very low. I’ve looked at the solder point for the sockets of the op amp and the CEM and they look fine, but just to make sure I’m going to take those part out of the sockets and apply a bit more solder to a couple of the socket points.

Here are some pictures of the boards. My soldering skills are not great, but I didn’t think they were to bad, obviously I over estimated them.





Ok I tried the bypass and it sounds exactly the same as with the CEM in. The volume pot is noisy when I turn it. I’m going to swap the two pots and see what happens. With the CEM in and in the filter page, when I change the cutoff and res values nothing happens.

You can remove and bypass the CEM3379 if you suspect there’s something wrong in this area.

You should still get the raw oscillator waveform, without filter and volume envelope…

I did solder the volume pots. I’m going to try the CEM bypass right now.

Dumb question: Did you solder the two volume pots?

Note that when you do the bypass, you get a quite beefy and solid output… So if it’s sounding thin, there’s a problem either in the connection with the pot, or with the op amp…

update: I think the problem is that the op amp and the CEM are not receiving power. I was looking at the voltage test points on the assembly page and decided to test the hack me strip’s +5v and ground with a test lamp (I don’t know if that is what its called, but its an alligator clip on one end and a pointy-screwdriver-looking thing on the other) Touching those two points powered the test lamp and the light lit up. Then I tested the +5v and ground of the main board’s lcd pins, again fine. The ATMEGA8 pin socket’s +5v and ground…fine. The CEM pin sockets +5v and ground…nothing…no light; same with the opamp’s +5v and ground. So is there a part or parts that if bad or improperly soldered would lead to no power reaching only the CEM and opamp?

Do you have a continuity tester? You could check:

  • That there’s no spurious connection between +5V and GND ; and -5V and GND
  • That all the GND points are at the same potential (same for +5V, -5V)

Another thing: the CEM3379 and the op-amp have a negative rail… maybe it’s the negative rail which is simply not there. You’d better get a cheap meter to check that!

will do.

ok so I borrowed multi meter and tested the power supply the way it is described in the assembly guide and I got a 11.43 volts…gulp…oh god I may have damaged something. Anything but the CEM please! Well if I did, the damage is done so I continued with the interlude tests and this is what I got:

Green (COM) and Purple (V) of the:

lcd = 5.06v
control board connector = 5.06
Hack me header = 5.06
Opamp socket =5.06
CEM socket = 5.06 with the center COM, 5.06 with the corner COM
ATMEGA socket = 5.06 with all the combinations of COM and Purple (V)

Green (COM) and Blue (V) :

Opamp socket = 0
CEM Socket = 0

I don’t know if those tests are the testing of GND points potential. If not how would I do that and which points would I use to test an unwanted connection between -5v and GND. The multimeter I have does have a continuity tester.

I feel like I kind of botched this job a little (not beyond repair I hope), but I’ve learned alot. Most importantly…slow down Zippy! I should have tested the power supply first then continued. Shruti 2, or whatever it is going to be called, will go smoother I’m sure.

thanks for the help people.

edit:

tested the input and output of the 7085 voltage regulator Input=7.6, output 5.06
and the input and output of the 7905: input= -0.10 and output= -0.10
I used the center pin of each regulator as the ground and the left for input, right for output.

The negative voltage regulator do not have the same pin order as the positive one. it is GND input, output.

To test for unwanted connection: put your meter in continuity mode, put one probe on GND, the other on -5V, and if it beeps, there’s a short on the negative rail.

Please check those things first - maybe it is the LT1044 that didn’t like something you did to it…

with power of I tested for continuity on 7905c between GND pin and -5v and there was none.

power on tested voltage of those same pins and it was 0.00
GND and input pin was 0.36

Look at the LT1044/MAX1044 on this image:

The pins are:

4 3 2 1


…(

5 6 7 8

Check that the voltage on pin 1 and pin 8 is x V, and that the voltage on pin 5 is -x V ; where x is the voltage delivered by your supply (11V in your case).

My best bet at the moment would be that this guy is dead - maybe by a voltage spike in your supply if it’s so beefy…