Ambika: Voices 1, 3 and 5 are not working. Possible fix?

I once got confused connected a 12v 1200mA plug form another synth into Ambika for 10 min. Would this have blown the voice cards 1 ,3 and 5?
Would you know if by mistaking the PSU i could have blown the voice cards 1 3 and 5? It was never smoke or burnt smell.

Also what could be the best solution to make voice 1 3 and 5 work? is it a hardware problem or a firmware issue?

Hmmm it’s a bit suspect that it’s only these voices. Are you sure it’s not a problem with the part/voice allocation settings?

Hi Pichenettes

Yes the part/voice allocation seems to be fine. I hope is just firmware issue and not hardware issue. I have recorded this little video explaining the issue.

This is the PSU I wrongly plugged.

Any help would be super grateful.


What do the voice activity LEDs (those on the voicecards) do? What kind of voicecards are installed inside?

Oh the LEDs of the three top voice-cards are off even if I activate them in the voice settings. The only LEDs that are lighting are the three at the bottom. They are 6 Polivok voice cards.

These are the cards:

I’d be first swapping voice cards around to see if it’s issues with the cards themselves, or control board/software.

Thanks, good idea but the problem is that i did not built the synth myself and i have no much knowledge in electronics so I am not sure if I will be able to switch the voice-cards and solder them back.

If this could be a software issue its easier for me tto do it. Shall I just reinstall the firmware via the SD card?

What’s the probability that the software would corrupt itself in such a way that everything seems to work as usual except voicecards 1, 3, 5 are defective?

Oh not sure if by plugging the wrong PSU 12v 1200ma for 10 min bugged the firmware and locked the voicecards , something similar to what is discussed here: Ambika voice card doesn't work. [Solved]

The thing is I cant find the frimware install guide as its a 404 error when trying to load the page.

Do you know where could i get the frimware and the guide to reinstall it and see if this fixes the issue?


This is not a firmware problem :slight_smile:

Bad luck hehe, I just tried to swap the voice cards in the first stack but now none is turning on. The one in the middle (closer to the motherboard has a super tiny light in the led but dont finish to turn on.

Now i have a 2 voice synth :slight_smile:

Would this be a mother board issue or a voice card issue? I havent swap them yet. I simply unplugged them and plugged them again as they were.

I just swapped the voicecards in the next stack and the bottom is lighting very little.

It seems to be an issue with the power supply? or the voicecards are not getting enough power?

This is the correct PSU Im using.

Pluggin in a PSU with more amps than suggested will not be the cause, the circuit will only draw the current it needs. Most likely things would be dry solder joints on the motherboard for the voice card terminals or issues with the jumpers. Grab a soldering iron and reflow all the voice card terminal solder joints and make sure the jumper are on properly and where they should be (A position when plugged into the board, B when stacked).
Find a port you know works, and test them one by one for power and data LEDs. IF they all work in port 2, then there’s controller board issues (dry solder joints somewhere probably). If some work and others not, then its issues with the cards themselves.

It also wouldn’t hurt to clean all the voicecard terminals with isopropyl.

Hello from the States!

Sorry to reboot this thread, but I’m having an incredibly similar situation and am not sure what action to take. I’m not entirely sure I should bust the unit open to perform maintenance nor am I entirely against it. I just feel that this is too similar a situation to be coincidence.

I recently purchased a completed 6 voice Ambika and was using the EU power source that came with it via a very nice, very reliable, step down converter. Everything was working perfectly. When the new 9V AC 1a power supply showed up, I swapped them out and booted up the Ambika. The instrument had not been used that day. The result: No sound at all. I immediately turned the machine off and went back to the EU psu. After a few moments, I turned the synth back on and this time, ONLY voices 1,3, and 5 are “active”. By pressing S6 and accessing the Voices page, I can manually turn the voices back on, but then there are still some dead keys on my controller. This is because voice card 3 is no longer producing sound from Mix out or the dedicated Line Out, even though it’s on and the LEDs are lighting up. Every time I boot it up it defaults to 1, 3, and 5 only.

I know this is long and you have my appreciation if you’ve made it this far.

Any help would be fantastic. Also an active link to reinstall the firmware would be greatly appreciated as well.

Thanks for your time!

There is no issue here. Every time the synth boots, it restores whichever settings have been saved to a special region of memory. See this post to find out how to save new settings permanently:

As for your damaged voice 3, check that it has the jumper that routes its output to the mix. If it’s not the cause of the problem, you’ll have to find where the signal path is broken.

Thank you so much for getting back to me.

I guess I just overlooked that other thread entirely. I appreciate you bringing it to my attention. I guess I was confused because the first couple of days that I was using the synth, turning it on and off, it was working fine with all six voices accounted for. Anywho, I’ll get on this right away.

Thanks again!