Ambika: voice card issue(s) / strange behaviour // (hopefully) RESOLVED //

Thanks a lot and sorry for the late reply - updating my hackintosh to 10.7.5 turned into a 24h project…

shiftr: Yes, this is the same with only one OSC running.toneburst: thanks for the hint, will have a close look and to some resoldering if needed.

I will also start the next voicecards, unfortunately I was stupid enough to order the wrong (wide) DIP28 sockets so it will probably take till Jan 2nd to have the next one ready for testing. I cut one of the (wide) IC sockets in half, so I could solder the 2 pieces independently (instead of the narrow socket). Or would you guys advise against this and rather wait for the proper parts?

Edit: Why the hell is vanilla replacing the ampersands?

Just cut them in half, if you solder them nice and straight should make no difference.

FINALLY! Seems like your hint @toneburst did the trick! I completely resoldered the DAC and now it sounds like a SMR-4 card :slight_smile: Will do some more testing but the obvious sound issues are gone!

@shiftr: thanks, height seems still OK (the wide socket is a bit higher as well) so I will probably try with one card. Can’t wait to get the beast polyphonic!

>>> THANKS EVERYONE for your support!

By the way, while I can switch to BP / HP filter, this affects nothing - I assume this is only relevant for the SVF cards(?)

BP / hp only works on SVF indeed.

OK, looks like I was a bit quick in declaring this resolved. I finally got the DAC chips and finished 5 more voicecards to discover 2 things:

(1) only the top slots (jumpered A) seem to work - the ones beneath (jumpered to B) don’t generate any sound (orange lights are on, no greens, the 3 control board leds on the right side also stay dark). Correspondingly, the individual outs 1, 3 and 5 have a signal, 2, 4 and 6 are quiet.
(2) The strange issues with the first voicecard seem to be on/off. My guess now is that it’s linked to the Arduino plugs, so that depending on how the card is inserted, it may or may not be correctly connected - is there a way to test this using a multimeter (no scope available)?

Thanks for your support (and patience)!

Voices 1,3 and 5 are by default assigned to part 1, voices 2,4 and 6 to part 2. Try removing them from part 2 and adding them to part 1.

@ByteFrenzy thanks a lot, this is an embarrassing case of RFM… Issue #1 is solved, all 5 cards play nicely now :slight_smile:

Will experiment with the first one…

Update: the 5 new voicecards are fine, the first one remains a problem. I noticed that it’s also louder than the others and sounds distorted by default. Also, it still show that strange LFO modulation…

Should I get a new PCB, save the chips and throw it away…?

I suspect you have a faulty power rail on the voicecard due to a bad connection and/or a short somewhere - but it’s hard to tell from the samples because I don’t know if you are playing your own sounds or presets. Playing the “init” sound or a well-known preset helps!

  • Pin 6 of a LM13700 = negative rail, should be 8V (+/ 10%)
  • Pin 11 of a LM13700 = positive rail, should be 8V (/- 10%)
  • IC6 pin 6: oscillators output. Try muting sub and oscillator 2, and set oscillator 1 to a clean sound line “sine” or “fm”. You should hear a clean sine wave here.
  • IC3 pin 8 ; IC2 pin 8 ; IC2 pin 9 ; IC3 pin 9: stage 1, 2, 3, 4 of the filter.
  • IC5 pin 7: voicecard output.

Thanks @pichenettes, Pins 6 and 11 of all LM 13700 look good (+8V/-8V exactly like on the other cards). I spent another 5 min with a magnifying glass and were not able to detect any shorts.

I recorded another sound demo using the Junon patch and 2 voicecards - first the “healthy” one, then the bad one. Looking at the waveforms the bad sounds are not centered, but shifted up, i.e. oscillating between 0 and max amp(?!?)

That nasty effect is (already) there when I turn off OSC2 and SUB and set OSC1 to sine.

Not sure how I can test the other pins using only a multimeter… Thanks again for your effort!

> Not sure how I can test the other pins using only a multimeter…

You don’t use a multimeter, you just hook them to an amp and listen to the signal.

Thanks Olivier, I ran the tests:

IC3 pin 8 ; IC2 pin 8 ; IC2 pin 9 ; IC3 pin 9: sound good :slight_smile:
IC5 pin 7: signal is screwed up here :frowning:

  • IC6 pin 8 should be at a high value (above 2V) while a key is held; then down to 0V when the key is released.
  • Check all solder joints around IC5; and IC4
  • Is Q1 correctly soldered?
  • Another check: remove IC4. Measure the current (in the mA range) flowing between pin 16 and pin 6 of the socket with a key released, and with a key pressed. Measure the current flowing between pin 1 and pin 6 of the socket with resonance = 0 and resonance = 63.

FINALLY! Looks like it’s solved!

@pichenettes: I resoldered IC4 and IC5 completely as well as the parts around (C10, R11…) and now it seems to be resolved! All 6 voices sound beautifully. Will check out this amazing machine in detail but the obvious problem is gone :slight_smile:

Thank you so much for your time and effort!