Ambika: voice card issue(s) / strange behaviour // (hopefully) RESOLVED //

I assembled the control board and tried to run any test as suggested before building/inserting the first SMR4 voice card. Without any voicecard, everything looks pretty good (display, pots working, can read from SD card). Few minor things I noticed my be normal:

  • when receiving a MIDI note, the symbol on the display flashes only for a very short moment, i.e. is hardly detectable(?). ON the Shruthi-1 I believe it is visible until the key is released, but I may not remember this correctly…
  • when Midi IN and OUT is connected to my keyboard, this seems to cause Midi loops, probably because the Ambika is set to “Midi through” somewhere(?).
  • when changing the POTs (e.hg. filter, resonance), no midi data seems to be transmitted(?) - guess this may also be linked to the “Midi through” mode.

After inserting my (so far) one and only SMR-4 voicecard (jumpered to A / A), LEDs on the voicecard seem to work fine, but things get ugly:

  • Sound is screwed up: sample1 sample2
  • System seem to behave erratic - sometimes a note played sounds at least a bit like the corresponding preset (on the Shruthi-1), sometimes not at all
  • After a while Ambika shows all presets as “(empty)”. After turning power off/on they appear again.
  • After a short while typically the system freezes (does not respond to anything any more).

My uneducated guess would be that something’s wrong with the voicecard (or card + board), so I attach a pic as well.

Thanks for any advice!

  • The display refreshes faster on Ambika so it’s normal that the note symbol is shown for less time.
  • The MIDI in and out should not be connected - it will create a loop, since the Ambika by default uses the out port for doing a “software thru”
  • Pots don’t send CC data by default, you have to change this option in the MIDI settings.
  • Do not insert a voicecard while the unit is powered on!

Regarding the crash/instability problem, does it happen only when the voicecard is inserted?

Thanks, voicecard has only been inserted / removed when the unit was unplugged.

Yes, it appears that the freezes only happen when the voicecard is in. However I’m not 100% sure of this. In general, the unit seems to be fairly slow, e.g. when jumping through presets, so sometimes it feels like it’s not reacting any more when it actually comes back a moment later. Is the speed of the SD-card relevant here?

By the way, when building the voicecard I used the 18pF capacitators that came with the kit instead of the 22pF written on the PCB, but I assume this is OK/intended.

Also, I now believe to remember that one of the 1K resistors measured only 950 ohm (if I measured correctly), which I thought is a bit off(?).

You should have used Caps that match the Quartzs Specs, for Reichelt sourced ones this is for example 33pf. If its a niggling representant of its kind it might not work with 18pf if 22pf is specified. IF you have a Scope you could check…

@fcd Thanks Frank, was not aware of this… So far I only used the parts provided in the kit - I assume Olivier had a reason to pick the 18p ones.

(I got myself the Horowitz for Christmas to gain some basic electronics knowledge, but I haven’t gotten to voicecard design yet :wink: Don’t have a scope either…

@Nordlead
By the way, when building the voicecard I used the 18pF capacitators that came with the kit instead of the 22pF written on the PCB, but I assume this is OK/intended.

Same here for me, i used the capacitors provided with the kits that are not the same written on the PCB.

Sorry for the confusion about the capacitors, but it is clearly not the cause of the problem. I have used 18pF on all my builds, and this is what comes with the kit.

The slowness when loading preset is normal - this is the time required to send the data to the voicecards + (if necessary) backup the current patch.

@pichenettes thanks for clarifying! Any hints to where the (sound) issues may originate from? Do the audio files give any clues?

Even though my Yellow Magic has a different filter, the output of the Ambika so far sounds way off / circuit-bent in a bad way. Any more (specific) testing I can do? The only thing I can think of is building the next voicecard (once the parts are here) and see if it behaves differently…

Again sorry to bother you.

I won’t be able to load audio before the 3rd.

The sounds you posted are quit short and could be normal sounds without a filter. But it does seem to sound a bit distorted but that could be a normal setting to. Is your filter working?

Some more testing seems to indicate that (filter and/or) resonance is not working properly - basically resonance seems to behave like a highpass:

Resonance set to 0: Filter seems to work (somehow) when cutoff is high (>90). Going down the signal dies around 65.

Turning the Res up thins out the sound in very audible steps, at 8 the signal is almost gone, at 9 it’s gone.

Res set to 63 (max): If cutoff is set to (around) 63 the raw signal passes (unfiltered I guess) with max volume. When increasing the cutoff from 69 to 70, however, signal is gone (silence)?! Same happens in the other direction, at 53 the signal is filtered and has a lower level, at 52 it is then turned off completely.

Can’t get the filter to self-oscillation. The typical resonance effect is not there at all.

Only certain waveforms seem to generate a sound (square, sine, others are silent). Again thanks for any suggestions!

Post a picture from the bottom side of the PCB

Should I also post the bottom side of the control board (if so, which areas)?

Have you tried the Voicecard in another slot? Maybe it’s a connection on the mobo

What is this white spot between c7 and c8? Generely it looks good. You cou try resoldering the whole thing and add some more solder on the points where there is not so much.

oh and especially the solder on the 220 ohms resistors near the connectors is a bit small.

@koerby: tried slots 2 and 3, didn’t make any notable difference.

@shiftr: thanks, the white spot turned out to be a tiny piece of a clipped lead, removing it and resoldering the 220 ohm resistors brought a slight improvement in sound (I believe), but resonance is still not working.

No more freezes today, though :slight_smile:

More testing and resoldering - Ambika project is gradually turning into a nightmare…

Resonance seems to work partially now, still no self-oscillation. One thing I don’t understand is some sort of modulation that’s been there from the very beginning (even when turning all modulation amounts to 0) - the frequency of that modulation follows/tracks the keyboard, i.e. is slow in the low keys, fast in the high keys: sample

I would guess that this means it’s happening on the digital side(?) - or is there anything I might have overlooked in the menus trying to turn it off?

I really appreciate any suggestions. (Can’t test with another voicecard as I’m still waiting for the parts to arrive)

it sounds like 2 oscilators beating. is it till there if you turn one oscilator of?

I experienced something like this modulation issue when building a MIDIbox project. Turned out in that case to be related to the DAC chip malfunctioning. Might be worth checking soldering round the voice card DAC.

a|x