Ambika v1.0 phase57 mod

Hey guys,

I tweaked my Ambika firmware some more and I thought I’d share it …
These are the changes so far:

  • added velocity and keyboard tracking parameters to the filter page.
    (assigned CC & NRPN for velocity (108) and keyboard tracking (109) parameters)
  • when saving, name/(empty) are now displayed while browsing for a location.
  • on the save page I added a ‘clear’ name button.
  • changed active parameter to fully uppercase instead of the first letter only.
  • set first character to ‘a’ when editing or entering new patch name, works a bit faster.

http://blog.phase57.com/index.php/ambika/code

source on GitHub

greetz

nice mods! some nice touches have always wanted

Most of these changes should benefit the official firmware as well. Pull request maybe? :wink:

Agree, these small yet useful mods could benefit everybody

I’ve been using the mod and I love it, thanks a bunch for the update. Quick question @soledad , Does the keyboard tracking parameter work the same as using the mod matrix for key tracking? I notice it’s not quite the same in the previous version.

should look into that bonobo, since its been a while since I added that parameter :wink:

You were right bonobo, I fixed it. It should now work the same as in the modulation matrix.

Nice man, I’ll try it out when I get home today. I just updated my firmware yesterday and the save feature is really nice! Thanks again for sharing your work, it is really appreciated.

Hey Olivier, when I fetch your “sustain pedal FIX” to my local repository and build the BIN file, its size is 65.536 bytes on disk (Compared to your BIN file which is still 61.440 bytes on disk), and when I upgrade Ambika, I get lots of gibberish on the screen.

It seems this happens only when I do a clean build (remove the build folder)

edit:
Although, come to think of it, it happened the first time I build as well while leaving the build folder as it was.

Any idea why this happens ?

Maybe you’re using a version of avr-gcc that is too recent? Make sure you are using version 4.3.3

http://mutable-instruments.net/ambika/build/firmware

yeah I’m using 4.3.3 (from WinAVR 20100110)

What do you get with make size? 61216 bytes here.

before FIX

text data bss dec hex filename
61332 100 3756 65188 fea4 build/ambika_controller/ambika_controller.elf

with FIX

text data bss dec hex filename
61356 100 3756 65212 febc build/ambika_controller/ambika_controller.elf

Strange… The numbers are a bit different but not extravagant.

On my side the .bin file is the size of text+data

Yeah strange indeed, after I removed the build folder again, build with the original file, then only deleted ambika_controller.bin, replaced part.cc with the fix and rebuild … the BIN file is the right size.

Hey,

i am using your mod and i love it !

some ideas of improvements :
would it be possible to make the navigation in the matrix somewhat easier ?
i thought of using the matrix button to cycle thru the matrix/mod entries ?

also editing the name of the presets while saving could be made much faster by using the remaining bottom buttons to :
-go left and right
-switch between lower case, upper case, numbers and signs.

i could help a bit in coding but i am scared of bricking my ambika. what are the risks there ?

cheers,

henri

You cannot “brick” the Ambika since the bootloader is located in a different segment of memory which is write-protected. At the very worst you’ll be able to reinstall the default firmware.

thanks olivier ! i feel safer.

i will give it a try then. does this also count for SD Card based flashing ?

Yes, SD Card based flashing is safe to do.

Thanx, glad you like it mots !

Some of those improvements are actually on my ‘to do’ list already :wink:

But I’m still having this build problem. Any new code I add since my last update causes the BIN file to be too large. Maybe I’m just hitting the limit of the program memory ? :slight_smile:

And now (prolly not related) the build process totally hangs my system. A lot of processes like make.exe (multiple instances) and avr-g++ together cause 100% CPU and I can only reboot. No errors from the compiler, just randomly freezes and doesn’t complete the build :frowning:
I tried on a virtual machine (WinXP and a fresh tool chain install) and it works, but the BIN file is still too big.