Ambika SMR-4 resonance problem [SOLVED]

Finally in the final stretch of building my Ambika (from the first run MI kit) - in addition to the MI kit-supplied SMR-4, I built 4 more SMR-4’s, and one SVF. All of those self-sourced voicecards are working fine, but the one using the parts sourced from the MI kit has very “weak” resonance. There is a change when you turn the resonance up, but it definitely doesn’t self oscillate. Swapping one of my other SMR-4 cards in the same position has the resonance behaving perfectly on that card.

I tried to follow the circuit diagram a bit, and ensured that IC4 and Q2 are OK. Where do I go hunting next?


Looks like caps C15 & C17 are on the wrong end of the position. They should be on the pins closest to the IC like C5 & C7

Indeed, these caps are now not connected at all (the holes they are in are connected to each other), which would explain the behaviour …

good find qp!

Good find, and to explain what’s going on here:

Without caps between the OTA output and ground (C15, C17), the corresponding 1-pole filter stage behaves like a 0-pole filter. So you ultimately get a 2-pole filter, with 90° instead of 180° of phase shift at cutoff, and hence a much weaker resonance with no possibility of self-oscillation.

Thank you qp!

And thanks Olivier for the technical explanation - I also wonder if it’s worth a brief mention in the build docs, to help others? It’s a minor miracle that I didn’t make the same mistake on the other 4 SMR voicecards…

Awesome! Glad I could help. Eagle eye (minus the cherry).

The capacitors listed on the BOM have a pin spacing that doesnt allow for this mistake. (at least the ones from Mouser)

Ah, that’s the reason I didn’t screw up my self-sourced boards!