Ambika screen goes weird when receiving MIDI notes [SOLVED]

Hi,

I have put together the controller board and a voice card and have started to test the build.
All seems to work apart from one thing. When I connect a sequencer to midi in the unit acts weird. Screen goes either blank or displays odd characters, the unit itself resets either the sound patch or freezes.

I have replaced 6n137 but this rendered no difference. I have not checked other parts in the chain though.

However, there is one thing I am aware of I did differently. I have programmed Atmels with TL866 programmer and it cant set fuse lock bit to 0x2f. It can only do 0xEF. And this is what I did. I recall checking MCU datasheet, which indicated that it should work. Could it cause the issue I am experiencing?

This are the settings I have used.

I have built a couple of Shruthis programming MCU this way and they work perfect.

I would appreciate any suggestions/comments/ideas.
Thank you.

EDIT: I forgot to mention that I have not soldered in all the leds.

EDIT2: I have missed to solder two 18pF caps next to the crystal on mobo. Problem solved.