Ambika "Pioneers" board run [all seats reserved]


#312

pichenettes suggestion 100 Ohms. Seems to look good, but I won’t know for sure until I can get the atmel’s loaded. Got me the tinyISP, just need some hex to put in it.


#313

The SD card should be FAT or FAT32 formatted. On OS X I reformat them using Disk Utility, can’t tell on another platform… If you have a card you think should work but doesn’t, you can send it to me and add I’ll look into it.

Have you check that the voltage for the 4050 is 3.3V? (and not 1.8V because of the wrong Vreg reference in the BOM at some point).


#314

I have uploaded the files

For the mobo:

Set fuses to:

LFUSE = ff
HFUSE = d2
EFUSE = fd
LOCK = 2f

Write ambika_controller.hex and ambika_controller_boot.hex to flash in the same avrdude command

For the voicecard:

Set fuses to:

LFUSE = ff
HFUSE = de
EFUSE = fd
LOCK = 2f

Write ambika_voicecard.hex and ambika_voicecard_boot.hex to flash + ambika_voicecard_eeprom_golden.hex to eeprom in the same avrdude command.


#315

@larsen: i’m in the same step as you, i got problem to use SDcard, i sended mine to pichenettes to see if SDcard filesystem is the problem.
beside that, i ordered differents 4050 to test them (a texas instrument, a STmicroelectronics and an ON semiconductor).
Pichenettes will tell us more about that.
it tried 2 SDcard, a strictly SD (2Go) and a SDHC (4Go) both formatted under Win7/64 (even tried with ChromeOS) one time with old FAT file system and one time with FAT32 (fast and real formatting). nothing seems to works.

edit, i corrected my BOM, it’s a 3.3V regulator on my MoBo (checked at the power test step).


#316

@pichenettes: thanks for the hex files! MoBo done! Now the VC…


#317

@pichenettes: I tried to format the SD cards in my Mac, no luck yet though… :frowning: I might send one to you later if I find no other way out, thanks for that! And yes, I got a 3.3 V regulator in place.

@gregmotorshop: Great, let me know your findings. From looking at the datasheet for the CD4050BE I got I suspect that it might simply be a bit slow to work reliably at the 10Mhz SPI speed that the Ambika apparently uses with the SD card. I’m thinking of getting a 74HC4050 instead… ( BTW, pichenettes, can I tweak the SPI speed for the SD card communication somewhere in the source without causing problems with other stuff? I might try that if so…)


#318

@larsen
Try formating the SDcard in your Camera - thats buletproof FAT :slight_smile:


#319

@fcd72, I actually tried that too… :slight_smile: Didn’t help though.


#320

What SD card brands are known to work? I would imagine Sandisk are bullet proof. But there are lots of fakes on ebay.


#321

You are totally right. I swapped in a CD4050 in my proto and the SD card stopped working. The two working protos both have 74hc4050. The part used is Farnell 380908 (74hc4050 from NXP).


#322

SD card code was tested with Sandisk 2 Gb and 4 Gb, Lexar 2 Gb, Transcend 2 Gb and noname 128 Mb. I have a few more in the mail following gregmotorshop’s message - I thought it was SD card related but the 4050 family error is going to be the explanation I think. Good catch larsen!


#323

Line that sets the SPI speed for SD card communication


#324

for me, one was a sandisk an the other is a panasonic…
i’ll receive all 4050s in few days, i’ll let you know if it can help by switching them.


#325

to late to add to my farnell order, but if none of the 3 i ordered will work i’ll re-order the NXP4050.
i’m happy that we surely find the solution !
EDIT: and it was the only issue with this ambika pioneer run ! thanks to pichenettes design and work.


#326

I can ship you one back with your SD cards.


#327

I was able to flash the MoBo no problem. Having an issue with the Voicecards. Set up the fuses: C:\\WinAVR-20100110\\bin\\avrdude -B 100 -V -p m328p -c USBtiny -P usb -e -u -U efuse:w:0xfd:m -U hfuse:w:0xde:m -U lfuse:w:0xff:m -U lock:w:0x2f:m then C:\\WinAVR-20100110\\bin\\avrdude -B 1 -V -p m328p -c USBtiny -P usb -U flash:w:ambika_voicecard.hex:i -U flash:w:ambika_voicecard_boot.hex:i -U eeprom:w:ambika_voicecard_eeprom_golden.hex:i -U lock:w:0x2f:m. ambika_voicecard.hex & ambika_voicecard_boot.hex load just fine but when ambika_voicecard_eeprom_golden.hex writes, i get this error

Ive tried several times and I keep getting the same error. When I connect the card to the MoBo, it the green LED reacts to MIDI but I am not getting any audio output. I have tried both the mix out and the dedicated out.

I am updating the card as a standalone. I am using the USBtiny for power. I tried jumpering the power off on the USBtiny then pluggin the VC into the MoBo and update that way, but it says initialization failed, rc=-1.

BTW, the 100R for the Optrex LCD works great. Plenty bright.

EDIT: I only have 1 board complete. I’ll finish another to see if I get the same error. Need to to go to the store for some more 8pin sockets.


#328

thanks a lot pichenette ! this is much appreciated.
I will still test the 3 other to see if one of them will do the job.


#329

Try unhooking the programmer from the board, then power-cycling the whole thing. Or try changing the voicecard assignment on the motherboard or loading a patch so that it sends patch data to the voicecard.

The reason is that the motherboard assumes that the voicecards have been powered at the same time as itself and that it has received the block of patch data sent during boot. As a result, when the voicecard boots minutes after the motherboard (because you have just flashed it), it is stuck with a blank patch and you have to do something to force the mobo to send it the patch data. That’s also why I recommend removing the programmer - by taking control of the reset pin it can mess with the reset sequence and cause the voicecard to boot later than the mobo (or boot twice).

Another thing: don’t do SD card writes when the programmer is still hooked to the mobo - it intereferes with the SPI bus (on AVRs, the ISP port is the same as the SPI subsystem) and this can cause random data corruptions on the SD card.

When I flashed the chips that I sent with the boards, my flash/test procedure was:

  • Hook ISP programmer to voicecard
  • Launch make bootstrap_voicecard
  • Check that green LED blinks with MIDI in
  • Unhook programmer
  • Power cycle mobo
  • Check that the green LED blinks with MIDI in and that I have sound

#330

pichenettes, thanks for the detailed response! I found the problem. I’m glad to know it’s nothing I did. But, I am very unhappy. I had a thought that even if I did not get any audio from the oscillators, I should still get sound from the filter in self oscillation. Of course, it was still dead. I happen to have a 2164 laying around from a previous order. I swapped it with the one in the VC and Voila! Up and Running! Of course this means that my overpriced source is a dud! Now to test the other 2.

FYI: I bought the 2164’s from these guys. I know I know, what the hell was I thinking! Live and learn. I will be going to Mammoth for my next order.

EDIT: Yep, ALL 3 2164’s ARE DOA Really in a “not happy” place at the moment. I Paid WAY to much for those and I know I will not get a refund. Gonna try though. But, DO NOT buy from them!


#331

CD4050 here too, I guess it is too slow.

I bought a SSM2164 from someone reputable on ebay (in the UK), it took an age to get a V2164 from the US last time.

Pricey though