Ambika Issue Weird Characters

Hoping someone might be able to assist… I have just finished an Ambika motherboard, tests all ok, though when adding all the IC’s, I turn on and get a bunch of weird characters… Any ideas of what this might be? See image below.

I can still press all the buttons and scroll through options with the encoder, but just it brings up different weird characters when I do this.

perhaps a reflow of the display / all components is needed? Have cleaned the board thoroughly, all joints look good.

Probably a bad solder joint in the connections between the MCU and the display.

Hmm, still no luck, re-flowed all connections… I’m thinking that it must be a failed component. Would anyone know which component it would likely be? Perhaps the IC 74165? I’m having a hard time figuring out the vital components between the MCU and display…

It’s because there is none. So if you are very confident about your traces and soldering, it can only be the display itself or the MCU.

Thanks. I think I may have found the issue, pin 6 of the display ‘E’ does not read any voltage. The specs state voltage level H, H>L, it is the ‘Chip Enable Signal’?

I have re-flowed this connection a couple of times now but still no difference…

How are you measuring this? With an oscilloscope?

Not with an oscilloscope, just a multimeter - all other pins are showing voltages (though i’m not sure if there should be a voltage on pin 6).

I’m using an OLED and have not soldered pins 15 & 16 (NC), I also don’t have a resistor or bridge on the ‘LCD’ as I understand it is not required.

I have also re-flashed the MCU and reset on boot-up (hold S1 and power on).

I’m starting to run out of ideas and am wondering if it is a faulty display, I really hope not as taking this off is going to be painful!

Two things:

  • There is a always a potential difference (voltage) between two points. This voltage can be 0V.
  • A multimeter will display the average voltage over a measurement time (which can be as high as a second). If the voltage is 5V for a very short amount of time, and is null the rest of the time. This is probably the case here as the pin 6 of the display is high only when the processor is sending data to the display - something that does not happen on a continuous basis.

Many thanks for the explanations. I have ordered another display as I can rule out all other possibilities. If that fails, I will order another MB and start over :wink: