Ambika freezing and screaming

Ambika assembled and playing beautifully. But after fifteen minutes or so, while playing and editing sounds, it kind of freezes and does a super high pitch (durable) tone. Very harsh. Sometimes there’s another, more ‘normal’ synthesized sound playing — but uncalled for. What could be wrong here, any ideas? Any hint much appreciated.

What kind of power adapter are you using? Maybe things are getting a bit hot?

second that - does she work again after a break ? (nice sentence btw…)

Hallo olbe

Please make following test: Play music with midi sequencer and dont touch your ambika. He plays without errors than you have a conaction problem in ambika hardware. Check this.

Greetings and good luck :slight_smile:

Thanks for the input mates!

@shiftr, I have a bunch of wall warts here, all +9V AC trying to figure out which works best, what polarity should it be by the way? (-centre negative?)

@fcd72, yes she sings fine again after a short break :slight_smile:

@rolfdegen, thanks I will run it hands of this evening and see how it behaves … cheers!

The adapter is AC (Alternating Current) so there is no negative or positive. They change around 50 times per second or 60 if you happen to be on another continent.

Put you multimeter on AC V measuring and measure the real output of the adapters. They are probably all higher without a load but go for the one wich is closest to 9V AC. Oh …and it should be at least 1000mA.

And please make sure that your adapters are actually AC-AC, and not the much more common AC-DC … If it says anything about centre pin (or outer pin) positive, it’s a DC adapter… Which is bad…

@olbe
then one of the regulators goes into high temperature protection shutdown… get bigger heatsinks. or dont stress her that much :wink:

ok, seems like the wall wart is fine after all, being proper 9v AC. Ambika is naked at the moment , placed by an open window with a lovely evening breeze coming through. Heat sinks feels quite hot however — perhaps the wall wart is crap after all, any suggestions where I can get a decent one?

Now playing MIDI notes without me editing or twiddling one bit … and Now it stopped, hanging on one note, after ten minutes. Sounds like a lush drone pad this time, but still, not intended. Green LEDs lighted, orange ones dead. It’s quite like a MIDI ‘panic’ thing really; most machines does this now and then, but not all the time, like this particular lady does.

any ideas? :-/

Ps. Lights up and plays just fine again after ‘rebooting’.

OK, skip for the regulaters if it works after reboot - you have somewhere a bad soldering joint presumably somewhere on the Power Rails…

Many Thanks! – hmm, now that’s a tricky one. The voltage measuring were good on all reference points when I assembled it. This is a bit confusing. Haven’t got a clue where to start looking to be honest …

Maybe get all the Voice-cards out but one… See if is still the same…

Actually there are some issues with certain ATMega644 MCUs that can cause them to sometimes crash on serial input. (It might in this case also depend on your choice of optocoupler etc.)
Try to boot it and leave it on for an hour without any MIDI input and see if it’s still responding (menus work, etc) after that.

Edit: It usually happens quicker than after 15 minutes, but maybe worth trying…

have you tried messuring the power rails while the problem occured?

Yeah, I’d try larsen’s suggestion:

  • 15 minutes on with no MIDI input at all (cable disconnected).
  • 15 minutes on with a LOT of CCs and notes.

If the first test case doesn’t cause any problem, and if the second causes a crash rapidly, you have a 644p/6N137 pair of death. The problem can be solved by changing one of them.

First, thanks to all of you for getting your heads around this.

ok the tests, it plays perfectly well on it’s own when the internal sequencer is running with no MIDI data feeding. Plays perfect without halting or glitching even while editing sounds. (The only twist so far that makes it stop, is when switching from mono/poly mode). hmm,.,.

So replacing the 6N137 chip (after properly checking the socket soldering) might be a good idea to start with?

Yes.

I am afraid these ‘pair of death’ chips were provided in a kit —no hassle intended here— Any spare ones laying around? … (if replacement turns out to be the solution).

Send me a private message with your address, I’ll send new ones. I would appreciate if you sent back the ones you have though!

Many thanks indeed, greatly appreciated!