4-pole mission filter board - Low sound / no res and output coming out of input [solved]

Ok, got my contrl board working now onto the next problem.

There is no res on the output from the filter board, just a quiet and distorted sound. If I plug the output lead into the audio in socket I can hear the raw waveform nice and loud.

I checked the voltages on the chips as in the guide, double checked I have the right chips in the sockets, the right way round etc. and everything looks ok.

Any more troubleshooting hints? I searched and found a few people with similar problems with the smr-4 mk11 board, but nothing on the 4 pole.

Cheers (again)

Have you soldered the bridge across the pads at the side of the sockets? (they are there so you can add volume pots or off board sockets).

Do you get sound at those points?

nope, just a pop when i first touch, voltages are reading 1.39 for 1,2,3 and -1.39 for 4

I’ve traced the sound from the schematic,

the signal is fine at the osc point, fine on both sides of c28 , fine on the 1st side of r20 but disappears on the other side, I’ve double checked and its a 100k resistor, also reheated it and it seems ok

hope this info helps

once again, thanks for the support!

  • Do you have signal at pin 1 of IC1?
  • What is the voltage at pin 7 of IC2 ; when cutoff is set to its minimal value and when it is set to its maximal value?

yes there is a signal, the sound drops off though, if i turn the res right up, I can hear the self oscillation and this is constant, doesn’t die off like the saw wave

the voltages on pin 7 of ic2 are 0.3 when cutoff is 0 and 0.5 when it is maxed out

Are you sure you get the self-oscillation tone at pin 1 of IC1 (this is supposed to be the mixer, before the signal enters the filter!)

There’s something wrong with the voltage at pin7 of IC2. It should go from 2V to 0V as you sweep cutoff.

OK, it now seems to be working! all i did was swap the tl072 chips on the top row and it worked! I straighted one of the chips as I swapped it, so i guess this was the problem.

only got one slight other problem / query. I’m trying to tune the res now, but everytime I play a key the note is slightly shifting each time, not while I hold the key down, just on each retrigger.

any ideas?

Make sure velocity isn’t effecting the cutoff frequency. Did you start from the init patch?

a|x

ah of course!

thanks :smiley: